none
Visual Studio 2010 - Outlook Add-in development RRS feed

  • Question

  • Hi All,

    I am new in the world of VSTO. I am developing an add-in for Outlook and everytime I want to debug it (from the VS 2010 IDE) I have to unistall the add-in from Outlook and very often I also need to run  mage.exe to clear the application cache.

    Is there any way to make the debug easier??

    Thank you in advance.

    Antonio

    Saturday, February 8, 2014 3:33 PM

Answers

  • Hi Antonio70,

    First of all, I'd recommend to uninstall the add-in and make sure that it is not registered and not loaded by the host application. Then you can try to build it and run for debugging. If you are still unable to debug, you need to check out the Disabled Items list. Microsoft Office applications can disable add-ins that behave unexpectedly. If an application does not load your add-in when you try to debug it, the application might have hard disabled or soft disabled your add-in. You can read more about this in the How to: Re-enable an Add-in That Has Been Disabled article in MSDN.

    Also you may find helpful the following articles that describe various VSTO issues you may be faced with when an add-in is being developed:

    Troubleshooting common VSTO issues – Part 1

    Troubleshooting common VSTO issues – Part 2


    • Edited by Eugene Astafiev Monday, February 10, 2014 1:49 PM
    • Marked as answer by Antonio70 Monday, February 10, 2014 2:11 PM
    Sunday, February 9, 2014 7:55 PM

All replies

  • Hello Antonio70,

    If you've already installed the add-in you can attach the debugger to the running instance of the host application (Outlook). Please read more about this in the Attach to Running Processes with the Visual Studio Debugger article in MSDN.

    In general, if you develop a VSTO add-in and are going to debug it, there is no need to install it. Instead, you need to build it and run for debugging (F5). You can read more about this in the Debugging Office Projects article in MSDN.

    Saturday, February 8, 2014 8:10 PM
  • Hi Eugene,

    Thank you for your reply.

    I still cannot solve my problem. In details here is what I am experiencing:

    If I start my project in Debug mode (F5), Outlook starts up but I do no see anything about my add-in;

    If I start my project in Release Mode (Solution Configurations), Outlook starts up and I can see my add-in; however, any future changes in my project will not be shown until I remove and re-release the add-in.

    My aim is only to debug the add-in at the moment but Outlook does not allow me to do it when I build and run (F5) it.

    Any help is welcome.

    Thanks.

    Antonio70

    Sunday, February 9, 2014 11:19 AM
  • Hi Antonio70,

    First of all, I'd recommend to uninstall the add-in and make sure that it is not registered and not loaded by the host application. Then you can try to build it and run for debugging. If you are still unable to debug, you need to check out the Disabled Items list. Microsoft Office applications can disable add-ins that behave unexpectedly. If an application does not load your add-in when you try to debug it, the application might have hard disabled or soft disabled your add-in. You can read more about this in the How to: Re-enable an Add-in That Has Been Disabled article in MSDN.

    Also you may find helpful the following articles that describe various VSTO issues you may be faced with when an add-in is being developed:

    Troubleshooting common VSTO issues – Part 1

    Troubleshooting common VSTO issues – Part 2


    • Edited by Eugene Astafiev Monday, February 10, 2014 1:49 PM
    • Marked as answer by Antonio70 Monday, February 10, 2014 2:11 PM
    Sunday, February 9, 2014 7:55 PM
  • Hi Eugene,

    Unfortunately none of the above mentioned tips helped. When in debug mode, opening the Modules Windows I have see that the symbols for my add-in cannot be loaded. Tried to check Outlook calls within Process Monitor and everything seems OK.

    I have then installed VSTO on a different host and everything works properly. I am happy with that; thank you for your support.

    Antonio

    Monday, February 10, 2014 2:11 PM
  • Good news! 

    You are always welcome, Antonio. 

    Monday, February 10, 2014 2:13 PM