none
VSTOInstaller /silent not supported RRS feed

  • Question

  • We currently have a number of users with an OLD add-in for Project that needs to be removed. I'm trying to use VSTOInstaller to remove the add-in through SCCM, but it wasn't built with support for the /silent option. Is there any way around this after the fact? Or any other methods I could possibly use to automate the uninstall from users where it's currently installed without prompting them?
    Friday, May 2, 2014 9:15 PM

All replies

  • Hello Cameron,

    What add-in are you talking about? Why do you need to use VSTOInstaller.exe, not the add-in installer?

    I'd recommend contacting the add-in developer instead. VSTO based add-ins can be installed silently.

    Saturday, May 3, 2014 6:26 AM
  • Perhaps I'm a little unfamiliar with .vsto files... We have a .vsto add-in sitting on a sharepoint server that users can install just by clicking on in their browser. Once installed, is there another way to uninstall it aside from "VSTOInstaller.exe /uninstall http://servername/addin.vsto" ? I've tried that same command line, but with the addition of "/silent" and I'm given an error saying that it's not supported.
    Monday, May 5, 2014 4:43 PM
  • > in sitting on a sharepoint server that users can install just by clicking on in their browser.

    The ClickOnce installer is used in that case. You can uninstall the add-in using the Control Panel applet.

    Monday, May 5, 2014 6:21 PM
  • Yes, but I'm trying to do this silently through the command line so that it's invisible to the end user.
    Monday, May 5, 2014 6:22 PM