locked
Cannot connect with 2 of my VM's using RDP RRS feed

  • Question

  • Hi,

    I have a problem connecting 2 of my VM's using RDP. I tried to Reset RDP configuration but the process goes on and on for more than 20 mins but didn't end. Even I tried to "ReDeploy" the VM as well but still cannot connect using RDP.

    I need your help to suggest the possible ways to get access to VM using RDP.

    UPDATE: The following is the response after resetting RDP Configuration

    VM 'WINSERVER2012R2' has not reported status for VM agent or extensions. Please verify the VM has a running VM agent and can establish outbound connections to Azure storage.

    I share the content of the error message as I am not able to upload the screenshot.

    ERROR SCREEN TEXT

    Remote Desktop can't connect to the remote computer for one these reasons:

    1) Remote access to the server is not enabled

    2) The remote computer is turned off

    3) The remote computer is not available on the network

    Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.


    • Edited by Deva2012 Thursday, March 28, 2019 10:37 AM
    Thursday, March 28, 2019 10:06 AM

Answers

  • Hi,

    I followed the document which u sent me. I reset the Private IP from dynamic to static and revert can work now.

    Thanks for your help.

    Thursday, March 28, 2019 11:49 AM

All replies

  • HI,

    Whats the error you are getting when you try to connect? Can you post a screenshot

    Check if the RDP port is open. Looks like all ports are blocked in the NSG which is attached to the VM.
    Thursday, March 28, 2019 10:08 AM
    Owner
  • Hi,

    I updated my question with Error message content.

    Here's the content from the Networking -> InBound Port Rules

    PRIORITY   NAME                                           PORT   PROTOCOL      SOURCE            DESTINATION       ACTION
    300           RDP                                              3389   Any                Any                   Any               Allow
    320           HTTP                                             80      TCP                Any                   Any               Allow
    340           HTTPS                                           443    TCP                Any                   Any               Allow
    65000       AllowVnetInBound                          Any    Any                VirtualNetwork    VirtualNetwork    Allow
    65001       AllowAzureLoadBalancerInBound     Any    Any                 AzureLoadBalancer Any               Allow
    65500       DenyAllInBound                             Any    Any                 Any                    Any               Deny

    • Edited by Deva2012 Thursday, March 28, 2019 10:46 AM
    Thursday, March 28, 2019 10:37 AM
  • Hi,

    Are you using a public ip to connect with the Windows server?

    We need to check the NSG which is attached to that vm.

    Go to the virtual machine in the portal and click on networking under "settings.

    It will list the NSG  associated with the subnet and the machine with the NSG rules.

    Make sure port 3389 is allowed. In the source you shouls have "Any" or your networks public ip address.

    Also go through this troubleshooting document and try out the steps which matches your scenario.

    Thursday, March 28, 2019 10:56 AM
    Owner
  • Hi,

    I already replied you the InBound Port rules for the VM.

    Here's the other set of info. available from the same page.

    Network security group WINSERVER2012R2-nsg (attached to network interface: winserver2012r2647)
    Impacts 0 subnets, 1 network interfaces

    I already tried the troubleshooting steps on the provided document.

    Thursday, March 28, 2019 11:19 AM
  • Hi,

    I followed the document which u sent me. I reset the Private IP from dynamic to static and revert can work now.

    Thanks for your help.

    Thursday, March 28, 2019 11:49 AM