locked
Exchange Hybrid, Approval Message issue. RRS feed

  • Question

  • I made a hybrid configuration with Exchange 2016.

    I set the rules in On-Premise and approval mail was sent to the O365 user.

    The approval email is received normally.

    However, when I click on the Accept or Decline button, I receive an NDR message stating that SystemMailbox{}@contoso.com cannot be found.

    I found and set the links below but it didn't work.

    What should I do?

    Please help me.....


    • Edited by Jisub Friday, July 3, 2020 7:29 AM
    Friday, July 3, 2020 7:27 AM

Answers

  • You can re-create the Arbitration mailbox using the below commands and check. Mount the exchange iso and run the prepareAD

    Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAD
    
    Get-User -ResultSize Unlimited | where {$_.Name -like "SystemMailbox{1f05a927*"} | Enable-Mailbox -Arbitration

    Reference: Recreate missing arbitration mailboxes


    Thanks,
    Ashok M My blog
    ________________________________________________________________
    Please mark the reply as an answer if you find it is helpful :-)
    ________________________________________________________________

    • Marked as answer by Jisub Wednesday, July 8, 2020 5:54 AM
    Monday, July 6, 2020 6:12 AM

All replies

  • Could you please share the complete NDR by removing the personal information. 

    Also, you can run the below command to check if the system mailbox exist in on-premise exchange,

    Get-Mailbox -Arbitration | fl name,displayname

    https://blog.ahasayen.com/hybrid-email-moderation-in-office-365/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    Thanks,
    Ashok M My blog
    ________________________________________________________________
    Please mark the reply as an answer if you find it is helpful :-)
    ________________________________________________________________

    Saturday, July 4, 2020 8:23 PM
  • I can't attach pictures due to account authentication issues.

    I can't attach a photo, so replace it with a description

    1. NDR Message

      - The message to SystemMailbox{D0E409A0-......D201}@consto.com could not be delivered.
         consto.com in SystemMailbox {D0E409A0-.......D201} (s) could not be found.

    ------------------------------------------------------------------------------------------------

    Original message details
    Created Date: 2020-07-05 11:52:12 PM
    From address: user@consto.com
    To address: SystemMailbox{D0E409A0-......D201}@consto.com
    title: Approve: Test

    Error details
    Reported error: 550 5.1.10 RESOLVER.ADR.RecipientNotFound; Recipient SystemMailbox{D0E409A0-......D201}@nepes.co.kr not found by SMTP address lookup
    DSN generation server: SL2P216MB0058.KORP216.PROD.OUTLOOK.COM

    ------------------------------------------------------------------------------------------------

        * error code 5.1.10

    2.  I can run the below command to check if the system mailbox exist in on-premise exchange.

      - Name : SystemMailbox{D0E409A0-......D201}

        DisplayName : Microsoft Exchange

      * the display name is not 'Microsoft Exchange Approval Assistant'.

    And I followed the instructions on the linked blog to complete the setup.

    From what I've found, the problem for others is permission issues, but my problem is that I can't find the system mailbox.

    Thanks for your answer.


    • Edited by Jisub Sunday, July 5, 2020 11:54 PM Add
    Sunday, July 5, 2020 11:50 PM
  • You can re-create the Arbitration mailbox using the below commands and check. Mount the exchange iso and run the prepareAD

    Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAD
    
    Get-User -ResultSize Unlimited | where {$_.Name -like "SystemMailbox{1f05a927*"} | Enable-Mailbox -Arbitration

    Reference: Recreate missing arbitration mailboxes


    Thanks,
    Ashok M My blog
    ________________________________________________________________
    Please mark the reply as an answer if you find it is helpful :-)
    ________________________________________________________________

    • Marked as answer by Jisub Wednesday, July 8, 2020 5:54 AM
    Monday, July 6, 2020 6:12 AM
  • I'll try the method you gave me.

    Thanks for answer.

    Wednesday, July 8, 2020 5:54 AM