locked
Silverlight App with metro IE

    Question

  • I have a SL app running on the web, and I can’t access it with the Metro IE. I was able to install the runtime in the desktop IE, but they don’t load from Metro. They said that it was the same engine, is there anything I could do to load SL from the Metro IE?

    Thanks,
    Louis  

    Wednesday, September 14, 2011 9:53 PM

Answers

  • Hey everyone,

     

    Take a look at the blog entry linked below to learn more about add-ons and the Metro style Internet Explorer in Windows Developer Preview:
    Metro style browsing and plug-in free HTML5

     

    You may already have seen this, but you can switch to the desktop version of Internet Explorer from the Metro style Internet Explorer to use add-ons/plug-ins on a website. This can be done by:

    • Right click the page or swipe your finger from the bottom of the screen to the center
    • Click the page icon displayed to the right of the Address bar
    • Click Use desktop version

     

    Then the desktop version of Internet Explorer will open.

     

    Hope that helps.


    Steven
    Thursday, September 22, 2011 12:31 AM
    Moderator

All replies

  • Apparently IE in Metro Style doesn't run plugins like Silverlight and Flash.


    Vitor Canova Weingaertner
    Wednesday, September 14, 2011 11:18 PM
  • i have the same problem.  Are all the Add-ons including their own 'silverlight' disabled?
    Thursday, September 15, 2011 2:52 PM
  • Hey everyone,

     

    Take a look at the blog entry linked below to learn more about add-ons and the Metro style Internet Explorer in Windows Developer Preview:
    Metro style browsing and plug-in free HTML5

     

    You may already have seen this, but you can switch to the desktop version of Internet Explorer from the Metro style Internet Explorer to use add-ons/plug-ins on a website. This can be done by:

    • Right click the page or swipe your finger from the bottom of the screen to the center
    • Click the page icon displayed to the right of the Address bar
    • Click Use desktop version

     

    Then the desktop version of Internet Explorer will open.

     

    Hope that helps.


    Steven
    Thursday, September 22, 2011 12:31 AM
    Moderator