locked
VSpackage editor failed in VS2010 SP1 RRS feed

  • Question

  • I create vspackage editor for vs2010 and vs2012. All works fine, and this day i try to fix bugs and reinstall again. It is works fine in VS2012, but got error in VS2010, package fail to load. I think it is not my package problem since it works fine in VS2012, maybe there is cache error in VS2010.

    I dont know what problem cause the error, since I don't change registry for VS2010, because it worked fine before. I try to do devenv /installvstemplates, /setup and /resetskippkgs and nothing can fix this.


    It's hard to be advanced programmer

    Wednesday, May 15, 2013 1:16 PM

All replies

  • Hi,

    To find what cause it, you can try the steps mentioned here:

    http://blogs.msdn.com/b/visualstudio/archive/2010/03/22/troubleshooting-pkgdef-files.aspx 

    to troubleshooting pkgdef.

    Hope it helps! If you have any concern, please feel free to let me know.

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, May 16, 2013 7:52 AM
  • Make sure you are  building your package with VS 2010, and not VS 2012. As you are attempting to target both versions of the IDE, you need to build your package with the earliest version of VS. The VS team does try to ensure packages built with older versions of VS can be retargeted to run under the newer versions of VS, but you cannot retarget a VS package to run on an older version of the IDE.

    Sincerely,


    Ed Dore

    Thursday, May 16, 2013 5:05 PM
  • I create 3 version one for VS2005, VS2008 and other for VS2010. This for VS2010 will be used also in VS2012. They all worked fine before in VS2005, VS2008, VS2010 and VS2012. But suddenly not working in VS2010.

    I was try to copy lib for VS2008 with other after bug fixed and get same errors, but after I do devenv /installvstemplates it works again. The strange thing is VS2010, because I do nothing but got same error like in VS2008.

    I use devenv /log for VS2010, and from log file, it said that my package library can not get 'Service' type from other library.

    FYI :

    1. both libraries is strong name and in same folder.
    2. VS2012 can load them well

    It's hard to be advanced programmer

    • Edited by IRW7 Friday, May 17, 2013 8:34 AM
    Friday, May 17, 2013 8:30 AM
  • I already found the bug in library reference by my editor. The strange thing VS2005, VS2008 and VS2012 ignore this null reference error, meanwhile VS2010 throw it as error and does not open the editor.

    It's hard to be advanced programmer

    Tuesday, May 21, 2013 5:59 AM