locked
Possible bug with package restore and Nuget 2 RRS feed

  • Question

  • Pushing to Azure fails for me even with new, plain vanilla MVC 3 site. Might have something to do with recently updated Nuget to v2. Repro repository available at: https://github.com/teelahti/TestKuduDeployment

    How to reproduce:

    • Create new ASP.NET MVC 3 web site (empty)
    • Add HomeController with Index action
    • Add Index View
    • Run to test locally
    • Enable nuget package restore
    • git init
    • git add .
    • git remote add azure [your address here]
    • git push azure master

    Expected: site published

    Actual: Fails on error message

    Counting objects: 82, done. Delta compression using up to 8 threads. Compressing objects: 100% (77/77), done. Writing objects: 100% (82/82), 476.24 KiB, done. Total 82 (delta 9), reused 0 (delta 0) remote: New deployment received. remote: Updating branch 'master'. remote: Preparing deployment for commit id '9875204017'. remote: Building web project 'TestKuduDeployment.csproj'. remote: C:\DWASFiles\Sites\kudurepro\VirtualDirectory0\site\repository.nuget\nuget.targets(76,9): error : Object reference not set to an instance of an object. [C:\DWASFiles\Sites\kudurepro\VirtualDirectory0\site\repository\TestKuduDeployment\TestKuduDeployment.csproj] remote: C:\DWASFiles\Sites\kudurepro\VirtualDirectory0\site\repository.nuget\nuget.target (76,9): error MSB3073: The command ""C:\DWASFiles\Sites\kudurepro\VirtualDirectory0\site\repository.nuget\nuget.exe" install "C:\DWASFiles\Sites\kudurepro\VirtualDirectory0\site\repository\TestKuduDeployment\packages.config" -source "" -o "C:\DWASFiles\Sites\kudurepro \VirtualDirectory0\site\repository\packages"" exited with code 1. [C:\DWASFiles\Sites\kudurepro\VirtualDirectory0\site\repository\TestKuduDeployment\TestKuduDeployment.csproj]

    Wednesday, June 20, 2012 8:20 PM

Answers

All replies

  • Hi Tero,

    Let me look into this issue and get back to you.

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, June 21, 2012 6:19 PM
  • Hi Tero,

    Team is looking into this issue and will get back to you soon.

    Thanks much for reporting this.

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, June 21, 2012 6:57 PM
  • Here is the bug that tracks this issue.
    Thursday, June 21, 2012 8:41 PM
  • Note that this bug is now fixed in NuGet, so you should not see this on new projects (and you can fix up existing ones).
    Friday, June 29, 2012 9:00 PM