none
BizTalk 2013 developer tools and .NET 4.5.2 support? RRS feed

  • Question

  • We're using BizTalk 2013 with VS2012. 

    In a new project we have the need to reference a library targeting .NET 4.5.2 but BizTalk 2013 developer tools only allows build target .NET 4.5. 

    Is there a way to add .NET 4.5.2 support to BizTalk 2013 developer tools, or is there some workaround? 

    BizTalk 2013 R2 seems to have a hotfix and CU2 that adds design tools support for .NET 4.5.2. 

    Friday, June 2, 2017 9:00 AM

All replies

  • Biztalk 2013 R2 supports .NET Framework 4.5.x and 4.6.*
    Biztalk 2013 supports  .NET Framework 4.5.x
    https://msdn.microsoft.com/en-us/library/jj248697.aspx

    What happens if you change target framework on your BizTalk 2013 projects from 4.5 to eg 4.5.2?

    rgds /Peter

    Friday, June 2, 2017 9:22 AM
  • The problem is that the BizTalk 2013 developer tools in VS2012 won't let me do this. 

    There seems to be a hotfix for BizTalk 2013 R2 that solves this, and it's solved in BizTalk 2013 R2 CU2. 
    But a hotfix is not available for 2013 that I know of, even with BizTalk 2013 CU5 installed the problem does not go away. 

    BizTalk 2013 supports .NET 4.5.2 but not the developer tools it seems. 

    Friday, June 2, 2017 9:55 AM
  • Ýeah got the same message on a small test project

    Very surprising as support for the .NET Framework 4, 4.5 and 4.5.1 has ended starting January 12, 2016
    https://blogs.msdn.microsoft.com/dotnet/2014/08/07/moving-to-the-net-framework-4-5-2/
    https://blogs.msdn.microsoft.com/dotnet/2015/12/09/support-ending-for-the-net-framework-4-4-5-and-4-5-1/

    rgds /Peter

    Friday, June 2, 2017 10:33 AM
  • Hi Sharpjusba,

    I am faced with this issue, were you able to solve or work around to this issue?

    Regards,

    Sibu

    Sunday, July 9, 2017 4:59 PM
  • Not as we speek

    I have addded a suggestion to the BizTalk Uservoice Forum
    Please add your vote as soon as it's public available, probably some time Monday 10th
    https://biztalk.uservoice.com/forums/383724-biztalk-server/suggestions/19991599-support-for-latest-net-4-5-x-framework-in-biztalk

    We need better support for .NET 4.5.x Framework in BizTalk 2013 In 2012 projects you can only select .NET 4.5 not later versions like in eg C# projects

    Servicepacks/update are only released for latest .NET 4.5.x version

    Thanks /Peter


    Sunday, July 9, 2017 5:31 PM