locked
CDN not working fine on my WordPress site, all end points are working on HTTPS RRS feed

  • Question

  • Hi Support, 

    I have implemented CDN on my WordPress Azure service and it is working fine, but when I enable CDN on the same site, <g class="gr_ gr_26 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="26" id="26">its</g> not working fine all the time. <g class="gr_ gr_28 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="28" id="28">Sometime</g> the CDN works, but most of the time, <g class="gr_ gr_27 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="27" id="27">its</g> not working and the images get loaded from my WP site. It worked for me once or twice, but again stopped without any error.

    This is impacting the load time and I am unable to move to production. I am on staging right now: https://advstaging.advaiya.com/ and following are the endpoints working on HTTPS.

    https://cdn1.advstaging.advaiya.com/

    https://cdn2.advstaging.advaiya.com/

    https://cdn3.advstaging.advaiya.com/

    https://cdn4.advstaging.advaiya.com/

    Your help would be highly appreciated.


    • Edited by IT_Advaiya Friday, May 26, 2017 4:57 AM typo
    Friday, May 26, 2017 4:56 AM

All replies

  • When you say the CDN stops working what is the behavior that you are seeing? What exactly stops working? If there is content that isn't being delivered from the CDN we will need an example URL and a HTTP response headers for that request to be able to better understand the issue you are seeing. If this is a critical issue to resolve, I would recommend that you open a support case.
    Saturday, May 27, 2017 12:53 AM
  • <g class="gr_ gr_5 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="5" id="5">Behvaiour</g> is that I cannot see CDN being applied in the source code. upon CTRL + U to view the source code, all the static resources still point to the domain and not the 4 CDN domains which <g class="gr_ gr_186 gr-alert gr_tiny gr_spell gr_inline_cards gr_run_anim ContextualSpelling multiReplace" data-gr-id="186" id="186">i</g> created. This is hampering the load time of my page/website.

    I have used WP Super cache as mentioned in the step by step guide and its implemented. 

    The URLs are working fine, but <g class="gr_ gr_378 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="378" id="378">its</g> not working on the website.

    Monday, May 29, 2017 6:55 AM
  • This isn't an issue with CDN configuration, so I am having a difficult time trying to resolve your issue.

    Testing the URL, none of the assets are being requested via the CDN urls, so it seems entirely like a Wordpress config issue. What happened between when you say it worked and when it stopped? Can you share the how-to page you followed?

    You may have better luck getting help on a Wordpress forum, or as Anton mentioned, opening a support case.

    Tuesday, May 30, 2017 8:49 PM