locked
I can't install activex on windows XP RRS feed

  • Question

  • Hello,

    I created an activex control for my web application. For installation on client I created with VS2008 a setup project. I packed the generated files by the setup project - setup.exe and ContabAX.msi installer together with ContabAX.inf file into .cab file with iexpress tool. ContabAX.inf file contains:

    [version]
    signature="$CHICAGO$"
    AdvancedINF=2.0
    [Add.Code]
    setup.exe=setup.exe
    ContabAX.msi=ContabAX.msi
    [ContabAX.msi]
    file-win32-x86=thiscab
    [setup.exe]
    file-win32-x86=thiscab
    [Setup Hooks]
    install=install
    [install]
    run="""%EXTRACT_DIR%\setup.exe"""
    ;run=msiexec.exe /package """%EXTRACT_DIR%\ContabAX.msi"""

    I need to run setup.exe, not .msi installer, to check if the prerequisites that are needed are installed on client. If not, these prerequisites are downloaded from my server (I set Url on setup project). If I run directly .msi installer and prerequisites are not installed on client installer redirect to the vendor page (the line is commented). On intranet it is not posibile to access external resources.

    On Windows 7 everything is OK but on Windows XP I have a problem:

    When confirm installation from browser the .cab files is deployed in TEMP folder into two subfolders TEMP\ICD1.tmp wich contains my .cab files and TEMP\VSD29E.tmp wich contains log.files (subfolder name are random generated). In TEMP folder is created an .msi file with random name (ex. d8082b.msi). This random .msi file is started by msiexec.exe. If prerequisites are not installed, during download prerequistes and install, TEMP\ICD1.tmp contains my .cab files. After prerequisites install is finished the files from TEMP\ICD1.tmp are deleted. If I go to the next step installation process I receive a error message: 'Error reading from file C:\Documents and Settings\<User>\Local Settings\Temp\ICD1.tmp\ContabAx.msi. Verify that file exists and that you can access it.' and can't continue installation process.

    If I try to install again or the prerequisites already installed setup.exe run shortly and going to the next step. Temp\ICD1.tmp folder is empty and I receive same error.

    If the prerequisites already installed and I run directly ContabAX.msi (I repacked .cab file to run msiexec.exe /package """%EXTRACT_DIR%\ContabAX.msi""" not setup.exe) the process intallation works fine.

     

    How can I solve this problem ?. Any ideas are welcome

    P.S. I have Windows 7 Professional 64 bit and VS 2008 SP1 on my machine

    Thursday, November 17, 2011 9:43 AM

All replies

  • Different system has different ways to run the installer file.
    NEU_ShieldEdge
    Monday, November 21, 2011 8:10 AM