none
New Broadcomm 8.1 WIFI no longer responds to ADHOC connection RRS feed

  • Question

  • Please let me know if there is a better place to post this

    We access wlanapi.dll through C# PInvoke to create and connect to ADHOC connections on our custom hardware device.

    This has worked for multiple WIFI drivers on Windows 7, 8 and 8.1.  Now with the Broadcomm 4324 802.12 abgn module it stalls on Associated.  A second kick will bring it to Connection complete state.

    We then set the IP, mask and gateway with WMI programmatically.  This is returning successful but an ipconfig shows no addresses on the interface.  And of course we cannot connect to our device

    netsh confirms that the interface is set with the profile.  The Network type is set to Adhoc, Radio type set to 802.11n

    • Does anyone know if there are known issues with that Broadcom driver
    • Does anyone know of additional ways to check for errors

    Many thanks

    Michael

    Friday, September 12, 2014 3:41 PM

All replies

  • Note that even if I create the connection with netsh and set the IP static with the same I get the same result
    Friday, September 12, 2014 6:15 PM