locked
User can no longer open personal views RRS feed

  • Question

  • I have a user that has 52 personal views created.  She can no longer add any additional views nor can she open or delete any of the ones she already had created.  

    We have just been using SharePoint 2007 since June (Moss).  The records are in a document library.  I have searched for a place to change limits but I haven't found where to go.

    What can I do to solve the issue?

    Thanks
    SBoyd 
    Friday, October 3, 2008 12:24 PM

Answers

  • Hi  Sboyd,

    The error message “The maximum number of Web Parts for all zones on this page has been exceeded” indicated the issue caused by the web part in the views or other web pages.

     

    I assume the personal views you mentioned is the web parts or web part zones, but not the personal view pages.

     

    And my solution is increase the number of the web part zones and web parts by modified the configuration file.

     

    If I am not misunderstanding your issue, you can change the number to 75 in order to solve your issue.

     

    Hope the information can be helpful.
    -lambert


    Posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, October 9, 2008 2:53 AM
  • run from CMD (it is an iis command that restart the web server.. not a SharePoint tool).

    It "kicks" out users as the IISreset command restarts the web server..so offline!

    Cheers,
    Daniel Bugday™ Web: © SharePoint Forum Blog: Daniel Bugday's Blog
    Thursday, October 9, 2008 12:34 PM

All replies

  • Hi Sboyd,

    do the user get an error message or something?

    Have you checked the logs in "hive12" or event viewer?

    I don't think there is a setting where you can specify the number of views for a user.

    Can someone else create a view?


    Daniel Bugday™ Web: © SharePoint Forum Blog: Daniel Bugday's Blog
    Friday, October 3, 2008 12:56 PM
  • Check you SSP, for the personalization permissions. It can be just dissabled to have access there.
    Or maybe the user has limited, "read" only rights

    My blog http://spaces.live.com/laflour | Visual C# MVP
    Friday, October 3, 2008 1:30 PM
  • The error message she received is:

     

    The maximum number of Web Parts for all zones on this page has been exceeded.

    Other folks can still create views but I'm sure this user has created more views than other users.  Her role requires her to view all records while other users are interested in a much shorter list.

    I know very little about SharePoint at this time.  I've never checked the logs in the hive12 and at the moment, I don't have access to the folders.

    The permissions on the SSP for all users is Create Personal Site and Use Personal Featurs.  I do have a permission group set up in the document library and I do not have the Delete Items checked because I didn't want users to be able to delete documents in the library.  Which settings need to be marked for users to be able to delete their own personal views but not delete items in the library?

    Friday, October 3, 2008 2:35 PM
  • Hi, 

    You can increase the MaxZoneParts in the web.config for the SharePoint virtual server.

     

    You could search for the following sections in the web.config file and modify them based on your requirements.

     

    <WebPartLimits MaxZoneParts="50" PropertySize="1048576" />

    <SafeMode MaxControls="200" CallStack="false" …………../>

     

    Please run “IISReset /noforce” to restart IIS server after you performed the operations.

     

    Hope the information can be helpful.

    -lambert


    Posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, October 6, 2008 5:20 AM
  • I finally found this file.  The only thing I would like to do is to allow the user the ability to create 75 personal views, so exactly what do I need to change?  Will I just change the 50 to 75 or does any of the other numbers need to be changed?

    Thanks
    Sboyd
    Wednesday, October 8, 2008 12:17 PM
  • Hi  Sboyd,

    The error message “The maximum number of Web Parts for all zones on this page has been exceeded” indicated the issue caused by the web part in the views or other web pages.

     

    I assume the personal views you mentioned is the web parts or web part zones, but not the personal view pages.

     

    And my solution is increase the number of the web part zones and web parts by modified the configuration file.

     

    If I am not misunderstanding your issue, you can change the number to 75 in order to solve your issue.

     

    Hope the information can be helpful.
    -lambert


    Posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, October 9, 2008 2:53 AM
  •  You understood correctly.  Does the "Please run “IISReset /noforce” to restart IIS server after you performed the operations" line run from CMD or is this a Sharepoint program than needs to run.  Can I run it during the day when users are logged on or do I need to take the server offline while it runs? 
    Thursday, October 9, 2008 12:19 PM
  • run from CMD (it is an iis command that restart the web server.. not a SharePoint tool).

    It "kicks" out users as the IISreset command restarts the web server..so offline!

    Cheers,
    Daniel Bugday™ Web: © SharePoint Forum Blog: Daniel Bugday's Blog
    Thursday, October 9, 2008 12:34 PM
  • I was finally able to do this on Friday but it didn't work.  I now have two users that are having the same problem.  Both of them had no problems until the number of personal views bypassed 50.  I changed the number to 75.  Do you have any other suggestions?

    Thanks for your help    
    sboyd
    Tuesday, October 21, 2008 1:09 PM