none
are all the net framework levels required? RRS feed

  • Question

  • On my system I have .net framework levels 1.1, 2.0 service pack 2, 3.0 service pack2 3.5 sp1 and framework 4 client profile. Do I need all these are are they cumulative levels?

    Thanks.

    Friday, April 27, 2012 5:54 PM

Answers

All replies

  • Hi Bobjdan,

    It's depend on your application. if you already installed all framework version. don't try to uninstall it.

    if you try to uninstall may be some application become unstable.

    Regards,

    Kalpesh


    Please "Mark as Answer" if this post answered your question. :)

    Kalpesh Chhatrala | Software Developer | Rajkot | India

    Kalpesh 's Blog

    VFP Form to C#, Vb.Net Conversion Utility

    Saturday, April 28, 2012 4:46 AM
  • Hi Bobjdan,

    Welcome to the MSDN fourm.

    Actually, I would suggest you do not try to uninstall them. Just as Kalpesh mentioned, whether you need them depends on your application.

    But you can have a look at this blog:

    http://blogs.msdn.com/b/astebner/archive/2011/10/02/10219046.aspx

    The title of this blog is "Do I need still need older versions of the .NET Framework on my system after installing the .NET Framework 4?"

    In general, my recommendation is to leave the .NET Framework 2.0 SP2, 3.0 SP2, 3.5 SP1 and 4 installed on your computer.

    Unlike previous versions of the .NET Framework, the .NET Framework 4 does not allow an application that was built with previous versions of the .NET Framework to migrate forward and run on it if the previous version is not installed. If you are using any applications that were built with any version of the .NET Framework before version 4, then I recommend leaving both the .NET Framework 3.5 SP1 and the .NET Framework 4 installed.

    The .NET Framework 1.0 and .NET Framework 1.1 can be installed side-by-side with the .NET Framework 2.0, 3.0, 3.5 and 4. Most applications that were created for the .NET Framework 1.0 or 1.1 will automatically use the .NET Framework 2.0 instead if it is installed on the system. In most cases, that means you do not need to keep the .NET Framework 1.0 or 1.1 installed on your system if you already have the .NET Framework 2.0 installed.

    All of the reasons have been listed on this blog.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Monday, April 30, 2012 6:14 AM
    Moderator