none
Dynamic Management CSP is not triggered even if it is successfully deployed on the device RRS feed

  • Question

  • Anyone has any idea why time based or IP based Dynamic Management csp not appliying when we change the Network or GeoLocation.

    <Replace>
          <CmdID>1</CmdID>
          <Item>
            <Target>
              <LocURI>./Vendor/MSFT/DynamicManagement/Contexts/NetworkWithTime/SettingsPack</LocURI>
            </Target>
            <Meta>
              <Type xmlns="syncml:metinf">text/plain</Type>
              <Format xmlns="syncml:metinf">chr</Format>
            </Meta>
            <Data>&lt;SyncML&gt;  &lt;SyncBody&gt;&lt;Replace&gt;&lt;CmdID&gt;1001&lt;/CmdID&gt;&lt;Item&gt;&lt;Target&gt;&lt;LocURI&gt;./Vendor/MSFT/Policy/Config/Experience/AllowCortana&lt;/LocURI&gt;&lt;/Target&gt;&lt;Meta&gt;&lt;Format xmlns=&quot;syncml:metinf&quot;&gt;int&lt;/Format&gt;&lt;/Meta&gt;&lt;Data&gt;0&lt;/Data&gt;&lt;/Item&gt;&lt;/Replace&gt;&lt;Final/&gt;&lt;/SyncBody&gt;&lt;/SyncML&gt;</Data>
          </Item>
          <Item>
            <Target>
              <LocURI>./Vendor/MSFT/DynamicManagement/Contexts/NetworkWithTime/SignalDefinition</LocURI>
            </Target>
            <Meta>
              <Type xmlns="syncml:metinf">text/plain</Type>
              <Format xmlns="syncml:metinf">chr</Format>
            </Meta>
            <Data>
              &lt;rule schemaVersion=&quot;1.0&quot;&gt;&lt;and&gt;&lt;signal type=&quot;ipConfig&quot;&gt;&lt;ipv4Gateway&gt;192.168.0.04&lt;/ipv4Gateway&gt;&lt;/signal&gt;&lt;signal type=&quot;time&quot;&gt;&lt;daily startTime=&quot;09:00:00&quot; endTime=&quot;23:00:00&quot;/&gt;&lt;/signal&gt;&lt;/and&gt;&lt;/rule&gt;
            </Data>
          </Item>
          <Item>
            <Target>
              <LocURI>./Vendor/MSFT/DynamicManagement/Contexts/NetworkWithTime/Altitude</LocURI>
            </Target>
            <Meta>
              <Format xmlns="syncml:metinf">int</Format>
            </Meta>
            <Data>10</Data>
          </Item>
        </Replace>

    returning 200 response, as well as I, can see its value is there in Regedit, but when I'm changing the Network(going into the IP the one I've mentioned), it is not able to disable the Cortana during the time frame, same I tried with GeoLocation as well but no luck.
    Tuesday, October 13, 2020 12:53 PM