none
datafactory.azure.com won't open

All replies

  • Are trying to open data factory version 2

    Please try this link: https://datafactoryv2.azure.com/

    Friday, April 13, 2018 6:54 PM
    Moderator
  • Hi VairavanS

    Why would you think I'm trying to open data factory version 2? The title clearly states what I'm trying to open

    Saturday, April 14, 2018 12:33 AM
  • Hi Dave,

    For data factory V1, you cannot directly open as data factoryv2. 

    Data factory v1 supports only two functionalities(copy, author and monitor) in that website, not entirely like v2.

    But For your case, you can do the below to make your life easier.

    The easiest way is to

    1. Go to your azure data factory resource
    2. Clicking on the required functionality.
    3. Bookmark the link and it would be easy for you to open it next time.(But you might have to login with your microsoft account)

    Please let me know if that helps


    Friday, April 20, 2018 8:08 PM
    Moderator
  • I'm not trying to open it directly.

    In azure, click on my existing data factory (v1)

    Under actions, there is a button "Monitor and Manage"

    I click this link, which tries to open datafactory.azure.com.

    I get as far as authorizing, but no further.

    Friday, April 20, 2018 9:58 PM
  • @Dave was the authorization successful? or did it throw an error?
    Monday, April 23, 2018 8:57 PM
    Moderator
  • Interesting... little different today

    IE Hangs at Authorizing. no errors shown

    EDGE: pure white screen, no idea whether authorization succeeded or not, no errors shown

    Chrome: Actually worked! three cheers for chrome

    Monday, April 23, 2018 9:07 PM
  • further note, it didn't come up right away, but in Edge developer tools, now seeing error: XMLHttpRequest: Network Error 0x80700013, http://download.microsoft.com/download/B/9/F/B9FF9327-7A72-4165-BF91-9B7EEB6C579B/DeviceList.json - the browser windows is still just a white screen though, no error message or anything displayed.
    Monday, April 23, 2018 9:08 PM
  • What version of IE and edge are you having?
    Tuesday, April 24, 2018 9:37 PM
    Moderator
  • IE: 11.2189.14393.0

    Microsoft Edge 38.14393.2068.0

    Tuesday, April 24, 2018 11:53 PM
  • Can try updating it to latest version and try it again?
    Wednesday, April 25, 2018 7:48 PM
    Moderator
  • Which do you think is out of date? IE is set to update automatically. While i don't see similar option in edge, the update status of my PC (windows 10) says device is up to date, checked today. I therefore assume they are both the correct version

    What versions of edge or IE are supported / not supported with azure data factory?

    Is there any reason that neither of these apps, with their present versions, are working?

    Any idea what the source of the error I reported is?


     
    Wednesday, April 25, 2018 9:11 PM
  • I tried replicating your error but I wasn't able to do so. I think the reason might be is that your cookies were not able to authenticate your identity.
    Thursday, April 26, 2018 10:48 PM
    Moderator
  • Deleted cookies in IE 11. no change, still doesn't work.

    tried inPrivate mode (IE11) No change, still doesn't work.

    VairavanS, is there someone from Azure that can actually provide support for this?

    Monday, April 30, 2018 3:26 PM
  • Sorry that any of the above didn't help resolve the problem. Another way to resolve is to contact Microsoft support directly as this issue needs more direct troubleshooting. 
    Tuesday, May 1, 2018 7:42 PM
    Moderator
  • Yes, worked with Microsoft Support directly for a while. Apparently it's a known issue, but Microsoft isn't willing to fix it because it's Data Factory v1. As mentioned though, version 2 of the data factory has severe limitation that v1 doesn't (using oauth), so it seems like Microsoft is just abandoning v1 without providing a sufficient replacement.
    Saturday, July 7, 2018 8:18 AM
  • Hi Dave, Abandoning v1 is not true. We are still maintaining it. So in your case, chrome is working now, right? But you still want to open it on Edge and IE?
    Sunday, July 8, 2018 2:12 AM
  • Hi Fang. I was specifically told by the product team that they were unwilling to fix v1, even though it is a known issue, because it's not v2. That sure sounds like abandoning v1 to me.

    Yes works in chrome. A lot of my customers though are government / utility companies, where the IT department only wants to support IE/ Edge, and won't allow users to install chrome on their computers. Hence for developing a solution for my customers, where typically I don't even have access to their production environment and they have to do all the setup / installation themselves in their domain, not being able to use IE / Edge can be very problematic.

    Erodes customer confidence when a microsoft product (Azure data factory) doesn't work with another microsoft product (Edge) and the response from the product team is 'sorry, we're not going to fix that bug'.

    Sunday, July 8, 2018 4:42 AM
  • Hi Dave,

    V1 should work in Edge/IE. In some rare cases, Edge/IE may not be able to open v1 UI. But we will investigate the root causes for those customers and help provide a workaround.

    Try different browser is just a workaround we provided. And now I understand it is not the right workaround for you. 

    From your description in this thread, you said when opening it in edge/IE, it just show a white screen.

    1. You hit this problem when opening "Monitor & Manage", right? Did you try "Copy data (preview)"?

    2. Could you share the screenshot? What is the url looks like when it shows a white screen?

    3. Did you disable third party cookies in Edge or ID? If yes, you need add cookie exceptions for the following two sites. 

    https://login.microsoftonline.com

    https://login.windows.net

    Have you tried this?

    4. Did you tried re-login portal.azure.com and then open "Monitor & Manage" or "Copy data (preview)" ?

    Monday, July 9, 2018 2:43 AM