VS 2012 RC becomes unstable after installing .NET 4.5 RRS feed

  • Question

  • Hi there

    I installed VS 2012 RC a couple of months back and have been developing on it right along, with no problems. The app I was developing targeted the new TAP/async features of .NET 4.5.

    Once my app was done, I created a setup program for it, which ended by prompting the user to upgrade their .net to 4.5. I invoke a link to Microsoft's program to install the newest .net 4.5

    To make sure my setup program works, I ran it on my machine, including running the .net 4.5 install.

    Now, Visual Studio has become unstable. Often it crashes before fully loading any project, or creating a new project. Other times, I get bizarre error messages. This morning, for example, when trying to open an app.config file, I get the error message "No exports were found that match the constraint: ContractName Microsoft.VisualStudio.Utilities.IContentTypeRegistryServiceRequiredTypeIdentity".

    I'm surprise that the installation of 4.5 as per my setup is so different than that the .NET installed by the VS 2012RC that it would unstabilize my VS.

    In hopes of "undoing" this, I tried to go back to MS site and download the original VS 2012RC, but alas, I can no longer find that download. (It appears we now have a Free 90 day trial product instead). 

    I'm not sure at this point how to get back to a stable VS 2012? Unfortunately, this is keeping from doing the work for which I get paid for.

    Any suggestions would be greatly appreciated!


    Wednesday, October 17, 2012 2:39 PM


  • There were significant changes made in .NET 4.5 from the pre-release versions to RTM. Enough that RTM VS 2012 will not even install on systems running pre-release .NET 4.5 (pre-release Windows 8).

    I believe your issue is because the RTM .NET 4.5 you installed on your system has affected your VS 2012 RC.

    As the RC is no longer available for download (along with the 4.6 that came with it), your only viable option is to remove VS 2012 RC, then install the RTM trial.

    • Proposed as answer by Ego Jiang Friday, October 19, 2012 1:23 AM
    • Marked as answer by Ego Jiang Tuesday, October 23, 2012 2:56 AM
    Wednesday, October 17, 2012 6:37 PM