locked
Issue with the second server on shared configuration after the account that runs under was changed RRS feed

  • Question

  • User-1801256968 posted

     

    Hello,
    I have two servers setup with shared configuration in IIS 7.
    I changed the user name for the shared config on Server1 to a service account with full admin rights locally.
    Then I went to Server2 and when try to open IIS it would not open the shared config file. obviously because of user name change. It give me an error pop-up:
    "There was an error when trying to connect. Do you want to retype your credentials and try again? 
    Details: Filename \\?\UNC\xx.xx.xx.\c$\Windows\system32\inetsrv\config\adminstration.config
    Error: Cannot read configuration file. "

    So I click on YES and get the Provide Credentials screen where it says:
    Connecting to "localhost"
    User name:
    Password:
    I provided the correct user name but it will still not connect.

    Then I went back to Server1 and change the credetials back to what I had before.
    Server 2 will still not connected to the shared config file.
    Furthermore I can't use IIS on the second box at all anymore. How do I change it to a local config file?

    Any ideas?

    Thanks
    Cosmin

    Monday, March 24, 2008 6:24 PM

Answers

  • User1073881637 posted

    What I did to get around this issue was as follows.

    1) Setup a domain account. 

    2) Create folder called IISSharedConfig

    3) Exported config to IISSharedConfig locally to say c:\inetpub\IISSharedConfig

    4) I installed DFS (replication only) on both nodes.  I replicate the local IISSharedconfig folder to both locations

    5).  Once DFS is completed. I go into the IIS on the second node, set it up to use the shared config file.   Make sure the 2nd node has the same folder created, I think DFS will create it.  Also verify the domain account has the appropriate permissions.

    When I was done, I renamed the administration.config and applicationHost.config located in the  default locations so IIS couldn't use them.

    Hope this helps. 

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, March 25, 2008 1:30 AM

All replies

  • User1073881637 posted

    What I did to get around this issue was as follows.

    1) Setup a domain account. 

    2) Create folder called IISSharedConfig

    3) Exported config to IISSharedConfig locally to say c:\inetpub\IISSharedConfig

    4) I installed DFS (replication only) on both nodes.  I replicate the local IISSharedconfig folder to both locations

    5).  Once DFS is completed. I go into the IIS on the second node, set it up to use the shared config file.   Make sure the 2nd node has the same folder created, I think DFS will create it.  Also verify the domain account has the appropriate permissions.

    When I was done, I renamed the administration.config and applicationHost.config located in the  default locations so IIS couldn't use them.

    Hope this helps. 

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, March 25, 2008 1:30 AM
  • User1073881637 posted

    Is your service account local?  As far as changing it back to local config.  Go into IIS Manager,click on the computer name on the left hand side, scroll down in the middle pane and uncheck the 'Use Shared Configuration' option.

    Tuesday, March 25, 2008 1:32 AM
  • User-1801256968 posted

    Hi Steve, I can't go into IIS Manager that is the problem, it will not let me open anything in less I type in the user/pass for the shared config. I think this is a bug in the product.

    Thanks

    Tuesday, March 25, 2008 11:39 AM
  • User1073881637 posted

    Is your shared config use a local copy of the file or is it on a UNC share?

    Saturday, May 31, 2008 1:01 AM