locked
Activation error occured while trying to get instance of type ExceptionPolicyImpl RRS feed

  • Question

  • Hi there, 

    I get a COM Exception and am not sure what to make of that.

    The error comes and goes, it was not showing for two days, and suddenly it reappeared. 

    It's definately related to one of the ReceiveLocations in BizTalk since it even repeats every 10 seconds (the exact Polling Interval with which the RL is configured)

    TeeTee.WrkMgmtIF.Pipelines.ReceiveSPWorkOrderFromSQL, TeeTee.WrkMgmtIF.Pipelines, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f4bb38a140c6efd8 

       TeeTee.SQLDisassembler 
       ReceiveSPTransmission_SQL 
       mssql://Test-SQL01/SQL2012/WIfaceDb? 
       Activation error occured while trying to get instance of type ExceptionPolicyImpl, key "Development Log Policy" 


    God bless you all :)

    Wednesday, June 8, 2016 3:55 PM

All replies

  • Hi 

    Check the BizTalk config file/machine.config file , it seems the error is being thrown from the EnterpriseLibrary Logging Block due to an incorrect config setting specified by the key "Development Log Policy". Please check if there are more events around the same time, that will give more hints. Probably similar issue to this.

    But the root cause is probably the Warning that you see for COMException. May happen due to Transaction TimeOut-

    http://blog.brandt-lassen.dk/2012_11_01_archive.html

    Solution:

    https://blogs.msdn.microsoft.com/ajit/2008/06/18/override-the-system-transactions-default-timeout-of-10-minutes-in-the-code/

    Add the following section in the machine.config file inside the root <configuration> section to set the maxTimeout to 1 hour. Restart Host Instances after the change :

     <system.transactions>
       <machineSettings maxTimeout=”01:00:00″ />
     </system.transactions>

    Also, make sure that the BizTalk config files(btsntsvc.exe.config and btsntsvc64.exe.config present in BizTalk installation folder) do not have a lower timeout specified. If not present, no need to add it. If present, that entry will look similar to below and the timeout value needs to be atleast equal to the maxTimeout value above -

    <system.transactions>
    <defaultSettings timeout=”01:00:00″ />
    </system.transactions>



    Thanks Arindam




    Wednesday, June 8, 2016 4:02 PM
    Moderator
  • Hello,

    Can you ask for downtime and  try rebooting the machine once.

    Refer: https://social.msdn.microsoft.com/Forums/en-US/05fa5035-10d3-4657-932b-b433c769174a/wcfsql-debatch-and-map-error?forum=biztalkgeneral


    Rachit Sikroria (Microsoft Azure MVP)

    Wednesday, June 8, 2016 4:04 PM
    Moderator
  • Hi, 

    This is a SIT machine so I can reboot it no problem.

    However, I would like to get to the bottom of that.

    1. Why is the error comming and going ?

    2. When I ping the Oracle server the time is < 1ms - clearly no 10min timeout needed ?

    3.  I would prefere no know (for future reference) which services need to be restarted (downtime not always is the option)


    God bless you all :)

    Wednesday, June 8, 2016 4:38 PM
  • Hi

    1. Do you mean the issue is intermittent? Are you able to receive messages over this ReceiveLocation at all?

    2. TransactionTimeout is not the same as server response time/latency. If there is a long-running query running on SQL, or if your query was blocked by some other lock/session, this will come into play. Generally, most transactions should be short-lived. But, the idea behind increasing the timeOut is to cater to the edge cases mentioned earlier.

    3. Generally restarting the Host Instance that hosts your WCF-SQL ReceiveLocation should work.


    Thanks Arindam



    Thursday, June 9, 2016 7:35 AM
    Moderator