locked
Unable to editing/oepn the sub site in SharePoint Designer RRS feed

  • Question

  • Hi, 

    I am using SharePoint 2007 and In one of hte site collectino having the site collection access and sub site level access(full control) also, but when i try to open one of the sub site in SharePoint designer 2007 i am getting the below error message.

    Error:'this web site has been configured to disallow editing with sharepoint designer. contact your web site administrator for more information'

    But when i try to open other sub site under the same site collection i don't have any issues and also i checked in the ONET.XML file and it does not have the property DisableWebDesignFeatures=wdfopensite.

    Please let me know if anybody knows the reason, why it is giving error only that subsite.

    Thanks,

    MSS

    Monday, May 6, 2013 8:58 PM

Answers

  • Hi All,

    i found some nice URL's to fix the issue.

    http://weblogs.asp.net/sharadkumar/archive/2009/06/10/sharepoint-designer-2007-governance-options-for-selective-lockdown.aspx

    http://blog.henryong.com/


    Run this the below code it will enable sub site open in SPD.

      
     using (SPSite site = new SPSite(txtsiteurl.Text.ToString()))
                {
                    using (SPWeb web = site.OpenWeb())
                    {
                       if (web.Properties.ContainsKey("vti_disablewebdesignfeatures2"))
                       {
                           if (web.AllProperties["vti_disablewebdesignfeatures2"].ToString() == "wdfopensite")
                           {
                               web.AllProperties["vti_disablewebdesignfeatures2"] = "";
                               web.Update();
                               lblproperty.Text = "found the property 'vti_disablewebdesignfeatures2' on this site:" + txtsiteurl.Text.ToString();
                           }
                           else
                           {
                               lblproperty.Text = "Not found the property 'vti_disablewebdesignfeatures2' on this site:" + txtsiteurl.Text.ToString();
                           }
                        
                        }
                    }
                }      

    The above code solved my issue.

    Thanks,

    MSS




    Friday, May 10, 2013 1:11 AM

All replies

  • Hi Syam,

    You can set this in the Central Administration for SharePoint. Do you have access to this? If so, here is how you enable/disable it on your site:

    1. Open Central Admininstration, click Application Management tab.

    2. Click User Permissions for Web Application, and make sure the option to "Add and customize pages" is checked.

     Make sure you are also part of the Designers (or higher) group on your site collection. 

    --------------------------

    Regards,

    Ankur

    Wednesday, May 8, 2013 1:01 PM
  • HI Ankur,

    Thanks for your mail.

    I have Central Admin access, but the option 'Add and customize pages' is already checked. I am having issue only this sub site, i am able to open other sites in SharePoint Designer.

    Thanks,

    MSS

    Wednesday, May 8, 2013 4:46 PM
  • Hi Syam,

    This is a bit long text but should resolve your issue. This is taken from http://support.microsoft.com/kb/2829174

    -------

    One possible cause identified for sites exhibiting this behavior, is if the site was created from a saved site template that had SharePoint Designer disabled. For example in a WSS 3.0 or SharePoint Server 2007 environment that had editing with SharePoint Designer disabled, the Site Collection Administrator or Site Administrator saved a site as a template by going to Site Actions, Site Settings, Save site as template and then created new sub-sites using that saved template. 

    Disabling the ability to edit a WSS 3.0 or SharePoint 2007 site with SharePoint Designer 2007 is done by adding the name/value pair of DisableWebDesignFeatures=wdfopensite to the <Project> element in the site definition's ONET.XML file. For more information about How to Prevent SharePoint Designer 2007 users from changing a Windows SharePoint Services 3.0 site or SharePoint Server 2007 site, click the following article number to view the article in the Microsoft Knowledge Base:

    940958 KB ARTICLE "How to prevent SharePoint Designer 2007 users from changing a Windows SharePoint Services 3.0 site or a SharePoint Server 2007 site"

    Creating a site template while these values are in place will cause sites created from that template to have a property bag name/pair of vti_disablewebdesignfeature2=wdfopensite. This is what is preventing editing of these sites with SharePoint Designer 2010 in the upgraded environment.

    You can confirm this is the issue by using the following PowerShell on the SharePoint 2010 Farm with the SharePoint cmdlets loaded. The following PowerShell must be run by an account that has Farm Administrator rights and has the Shell Admin permission for the content database that contains the site collection that is experiencing the issue.

    $web = Get-SPWeb <http://name.domain.com/sites/sitename/sub-site>   
    $web.AllProperties

    **Note:  You will need to remove the <> and replace the sample values supplied above with the URL to the sub-site experiencing the issue.**

    You will notice that the vti_disablewebdesignfeatures2 contains a value of wdfopensite

    How do I fix the problem

    To resolve the issue, enter the following command in the same PowerShell window:

    $web.AllProperties.Remove("vti_disablewebdesignfeatures2")
    $web.Update()

    How do I know the problem was fixed?

    You can verify the resolution by opening the sub-site in SharePoint Designer 2010 and ensuring that you are able to edit the sub-site. You can also verify the issue is resolved by entering the following command in the same PowerShell Window:

    $web.AllProperties

    The vti_disablewebdesignfeatures2 will no longer appear in the properties.

    Thursday, May 9, 2013 1:20 PM
  • Hi All,

    i found some nice URL's to fix the issue.

    http://weblogs.asp.net/sharadkumar/archive/2009/06/10/sharepoint-designer-2007-governance-options-for-selective-lockdown.aspx

    http://blog.henryong.com/


    Run this the below code it will enable sub site open in SPD.

      
     using (SPSite site = new SPSite(txtsiteurl.Text.ToString()))
                {
                    using (SPWeb web = site.OpenWeb())
                    {
                       if (web.Properties.ContainsKey("vti_disablewebdesignfeatures2"))
                       {
                           if (web.AllProperties["vti_disablewebdesignfeatures2"].ToString() == "wdfopensite")
                           {
                               web.AllProperties["vti_disablewebdesignfeatures2"] = "";
                               web.Update();
                               lblproperty.Text = "found the property 'vti_disablewebdesignfeatures2' on this site:" + txtsiteurl.Text.ToString();
                           }
                           else
                           {
                               lblproperty.Text = "Not found the property 'vti_disablewebdesignfeatures2' on this site:" + txtsiteurl.Text.ToString();
                           }
                        
                        }
                    }
                }      

    The above code solved my issue.

    Thanks,

    MSS




    Friday, May 10, 2013 1:11 AM
  • You've given a SharePoint 2010 answer when the OP clearly states that he has SharePoint 2007.  Most of these links will be limited in their usefulness.

    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/

    Friday, May 10, 2013 8:38 AM
    Answerer