none
Can't build C++ project: "Windows SDK 8.1" not found, however, it is installed. RRS feed

  • Question

  • I'm receiving following error trying to compile trivial "hello world" in C++:
    "MSB8036". The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK version in the project property pages or by right-clicking the solution and selecting "Retarget solution". C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\Win32\PlatformToolsets\v140\Toolset.targets.

    However, I have installed Windows SDK 8.1 from here: https://developer.microsoft.com/ru-ru/windows/downloads/windows-8-1-sdk. Launching "sdksetup.exe" from downloaded "StandaloneSDK" gives a "The features installed on this computer are up-to-date".

    I thought that something may be broken with my Visual Studio installation, so I've trier to repair it first (no results), then tried to remove and install again (no results). Then I thought that it may be some issues with SDK installations, so I've removed VS and all SDK's, and installed everything again - still no results.

    Most probably, something with paths and/or environment variables is broken, but I don't know how to trace and debug those issues in Windows.

    I'm using Microsoft Visual Studio Enterprise 2015, ver. 14.0.25431 Update 3, Windows 10.


    Friday, December 9, 2016 12:49 PM

All replies