none
SDL Threat modeling tool says "Visio is not installed" when start up (Both Visio Premium 2010 and Prof 2007 installed) RRS feed

  • Question

  • It is so troublesome and frustrated trying to use SDL Threat modeling tool :(. A little bit of background:

    I got some problem with latest Office beta so I uninstalled all and installed Office 2012 Professional again. Prior to this, SDL threat modeling tool worked fine. After I reinstalled Office 2010 + Visio Premium 2010 + Visio Prof 2007, SDL Threat Modeling tool doesnt work anymore. I reinstalled it and I was able to install successfully (no Visio question pop up). However, every time I start Visio 2010 I got this pop up:

    "Visio is not installed. Please install Visio 2007 or 2010 before using this tool"

    This is not very robust the way SDL tool works.

    Thanks.

    Monday, May 14, 2012 5:54 PM

Answers

  • Dear sir,

    Office beta is not supported for SDLTM tool.

    Does Visio 2010 start when you launch it? Or does it go through repair? Could you uninstall Visio 2007 or you must have both versions of Visio installed on this box?

    What is the name of the folder where VISIO.EXE is installed for Visio 2010?

    Try the following:

    1. Uninstall Visio 2007

    2. Repair Office 2010 and Visio 2010

    3. Launch Visio 2010 for the first time launch initialization.

    4. Uninstall the SDLTM tool and reinstall it. Reboot if asked.

    Let us know if that helped.

    Adel.

    Tuesday, May 15, 2012 5:32 PM