locked
download-batch failing with "ResourceNotFound" when using snapshot RRS feed

  • Question

  • Hi,
    I perform the following steps:

    1. Take snapshot of the storage file share
    2. Then create a file in the share
    3. And then try to download the snapshot version of the share with:
      az storage file download-batch ... --source [SHARE-NAME] --destination mydir --no-progress --snapshot [SNAPSHOT-NAME]

    At this point, the download fails with:

    The command failed with an unexpected error. Here is the traceback:
    
    The specified resource does not exist. ErrorCode: ResourceNotFound
    <?xml version="1.0" encoding="utf-8"?><Error><Code>ResourceNotFound</Code><Message>The specified resource does not exist.
    ...
    If I look in the destination directory, I can see that the new file (which does not exist in the snapshot) is in the directory

    Any help gratefully accepted,
    Jimmy

    Wednesday, July 17, 2019 8:54 AM

All replies

  • thanks for posting Jimmy, Would it be possible to try the same action using Azcopy ? you can download the latest version from here: https://github.com/Azure/azure-storage-azcopy 
    Let me know if you get any other error messages. 

    Wednesday, July 17, 2019 10:42 PM
  • @Jimmy the dog Just checking in to see if the above answer helped. If this answers your query, do click “Mark as Answer” and Up-Vote for the same, which might be beneficial to other community members reading this thread. And, if you have any further query do let us know.

    Wednesday, July 24, 2019 7:53 AM
  • Hi Adam,

    Thanks for replying

    I've just quickly ran an AzCopy docker image, but I don't see any argument to specify a snapshot - am I missing something?

    Wednesday, July 24, 2019 8:31 AM