locked
Schema build error in biztalk project RRS feed

  • Question

  • Hi All,

    getting below error while building the schema project in 2012 vs .

    Error 1 Unable to copy file "obj\Release\" to "obj\Release\Schemas.Clr Types.dll". Access to the path 'obj\Release\Schemas.ClrTypes.dll' is denied in biztalk

    Thanks,

    Santosh.


    • Edited by Santosh_Biz Thursday, September 1, 2016 2:47 PM
    Thursday, September 1, 2016 2:44 PM

Answers

  • Hello,

    Did you try the steps mentioned below? I am sure anyone of them will fix it for you.

    Its running under administrator.I have reopened the VS with administrator user,still same error.



    Restart the visual studio solution and try cleaning the solution and rebuilding again (may be batch build). Check if you have any postbuild event written for the project which might be causing problem. 

    Also Refer: https://psrathoud.wordpress.com/tag/access-to-the-path-is-denied/

    1>Make sure you run your VS as administrator.

    2>Check for the file on which request is denied error is thrown has the read only property unchecked.

    3>Try deleting the file if you are able to do indicates there is no lock on the file, if not :kill the process which is having the lock. In this situation restart is a good medicine😉. Please use your discretion while doing that.

    4>Trying clean from the visual studio and recompile after you have verified the above two. If still not in luck. Close all the instances of VS and go to Task Manager and see if there are any active instances of VS.

    5>Use process explorer to verify as well: https://technet.microsoft.com/en-us/sysinternals/bb896653

    6>Turn on windows service :- Application experience
    Computer (right-click) -> manage -> Service & Application -> service -> Enable Application experience


    Rachit Sikroria (Microsoft Azure MVP)




    Rachit Sikroria (Microsoft Azure MVP)

    Thursday, September 1, 2016 4:15 PM
    Moderator

All replies

  • Hi Santosh,

    Please open Visual Studio as administrator and then try to build your BizTalk project.



    Rachit Sikroria (Microsoft Azure MVP)

    Thursday, September 1, 2016 2:52 PM
    Moderator
  • Its running under administrator.I have reopened the VS with administrator user,still same error.


    • Edited by Santosh_Biz Thursday, September 1, 2016 2:55 PM
    Thursday, September 1, 2016 2:54 PM
  • Close ur Visual studio and re run as Admin. Open the solution and build again.

    Pi_xel_xar

    Blog: My Blog

    BizTalkApplicationDeploymentTool: BizTalk Application Deployment Tool

    LinkedIn: LinkedIn

    Thursday, September 1, 2016 2:54 PM
    Answerer
  • Its running under administrator.I have reopened the VS with administrator user,still same error.


    Restart the visual studio solution and try cleaning the solution and rebuilding again (may be batch build). Check if you have any postbuild event written for the project which might be causing problem. 

    Also Refer: https://psrathoud.wordpress.com/tag/access-to-the-path-is-denied/

    1>Make sure you run your VS as administrator.

    2>Check for the file on which request is denied error is thrown has the read only property unchecked.

    3>Try deleting the file if you are able to do indicates there is no lock on the file, if not :kill the process which is having the lock. In this situation restart is a good medicine😉. Please use your discretion while doing that.

    4>Trying clean from the visual studio and recompile after you have verified the above two. If still not in luck. Close all the instances of VS and go to Task Manager and see if there are any active instances of VS.

    5>Use process explorer to verify as well: https://technet.microsoft.com/en-us/sysinternals/bb896653

    6>Turn on windows service :- Application experience
    Computer (right-click) -> manage -> Service & Application -> service -> Enable Application experience


    Rachit Sikroria (Microsoft Azure MVP)


    Thursday, September 1, 2016 2:59 PM
    Moderator
  • Still same error.

    Load Balence

    Thursday, September 1, 2016 2:59 PM
  • Did you try just deleting Schemas.ClrTypes.dll with Windows Explorer? 

    If the project was added to any Source Control incorrectly, the output will be marked Read-Only.

    Thursday, September 1, 2016 3:35 PM
    Moderator
  • Hello,

    Did you try the steps mentioned below? I am sure anyone of them will fix it for you.

    Its running under administrator.I have reopened the VS with administrator user,still same error.



    Restart the visual studio solution and try cleaning the solution and rebuilding again (may be batch build). Check if you have any postbuild event written for the project which might be causing problem. 

    Also Refer: https://psrathoud.wordpress.com/tag/access-to-the-path-is-denied/

    1>Make sure you run your VS as administrator.

    2>Check for the file on which request is denied error is thrown has the read only property unchecked.

    3>Try deleting the file if you are able to do indicates there is no lock on the file, if not :kill the process which is having the lock. In this situation restart is a good medicine😉. Please use your discretion while doing that.

    4>Trying clean from the visual studio and recompile after you have verified the above two. If still not in luck. Close all the instances of VS and go to Task Manager and see if there are any active instances of VS.

    5>Use process explorer to verify as well: https://technet.microsoft.com/en-us/sysinternals/bb896653

    6>Turn on windows service :- Application experience
    Computer (right-click) -> manage -> Service & Application -> service -> Enable Application experience


    Rachit Sikroria (Microsoft Azure MVP)




    Rachit Sikroria (Microsoft Azure MVP)

    Thursday, September 1, 2016 4:15 PM
    Moderator
  • Try deleting all bin and obj folder from solution after closing  VS AND THEN TRY REBUILDING..

    Pi_xel_xar

    Blog: My Blog

    BizTalkApplicationDeploymentTool: BizTalk Application Deployment Tool

    LinkedIn: LinkedIn

    Thursday, September 1, 2016 4:39 PM
    Answerer
  • Thanks for your help.

    Restarted my VM then it is working fine.


    Load Balence

    Thursday, September 1, 2016 5:28 PM