locked
[UWP] App not displaying correct Language RRS feed

  • Question

  • My application is not showing the correct language even after setting up multilingual app toolkit and all the steps associated with it. Even the store recognizes that the languages are present but yet the app shows English only irrespective of display language. 

    Thursday, January 12, 2017 7:15 AM

Answers

  • Hi Bhavya Shah26,

    If you want to set the string in resources.resw to TextBlock, you should be able to use "Hi.Text" to instead of "Hi" of the name in resources.resw file.

    When I change the default language in Languages, the text will change.


    Best Regards,

    Jayden Gu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Jayden Gu Monday, February 6, 2017 9:41 AM
    • Marked as answer by Bhavya Shah26 Sunday, March 12, 2017 5:41 AM
    Monday, February 6, 2017 9:41 AM

All replies

  • Guys any Help?

    Sunday, January 15, 2017 12:46 PM
  • Hi Bhavya Shah26,

    Have you set the Generate app bundle?

    For apps that target Windows 8.1, Windows Phone 8.1, and later, Visual Studio can generate an app bundle (.appxbundle) to reduce the size of the app that users download. This can be helpful if you've defined language-specific assets, a variety of image-scale assets, or resources that apply to specific versions of Microsoft DirectX.

    For more info, see App bundles.

    When we use the Appx Bundle by setting it as "always" or “if needed”, by default it will only download the resources file relevant to the language of the device.

    There is a similar case, please refer it in this link: https://stackoverflow.com/questions/39107907/uwp-resource-file-for-languages-is-not-deployed-correctly/39119126#39119126.

    You should be able to set the "Generate App bundle" to "never".

    Also if you want to use the Appx Bundle and keep all the language resources in the package as well, please follow the steps mentioned in this article: Windows 8.1 Store apps: Ensure that resources are installed on a device regardless of whether a device requires them.


    Best Regards,

    Jayden Gu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Jayden Gu Sunday, January 22, 2017 12:15 PM
    Monday, January 16, 2017 5:27 AM
  • Previously I never had to change it to Never option. I am facing this issue of late.
    Tuesday, January 17, 2017 3:25 PM
  • Here is a link to the sample I created: https://1drv.ms/u/s!Ar2Oon4jkTNAqdkRe4R6gpr6DOXRDw

    Also I just want the app to show whichever is the default display language which is not happening.

    Tuesday, January 17, 2017 5:29 PM
  • Hi Bhavya,

    >>Previously I never had to change it to Never option.

    Please refer my previously answer, you should be able to set the "Generate App bundle" to "never".

    Also your sample is .rar that we can not open it. You should be able to zip it to .zip.


    Best Regards,

    Jayden Gu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Sunday, January 22, 2017 12:15 PM
  • I tried It didn't work. Using Never to create different packages but yet I got the same result.

    New Link with .zip file-https://1drv.ms/u/s!Ar2Oon4jkTNAqfJblNIUHK4mC-vT3Q

    Wednesday, January 25, 2017 5:42 AM
  • Hi Bhavya Shah26,

    If you want to set the string in resources.resw to TextBlock, you should be able to use "Hi.Text" to instead of "Hi" of the name in resources.resw file.

    When I change the default language in Languages, the text will change.


    Best Regards,

    Jayden Gu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Jayden Gu Monday, February 6, 2017 9:41 AM
    • Marked as answer by Bhavya Shah26 Sunday, March 12, 2017 5:41 AM
    Monday, February 6, 2017 9:41 AM