none
File Icons are missing in Visual Studio 2015 Solution Explorer Tree View

    Question

  • Hi

    We have registered templates with our own file extensions (*.inbp, *.indp) in Visual Studio. Unfortunately, the icons of file extensions are not shown in the tree view of the Solution Explorer in Visual Studio 2015. In Visual Studio 2012 the icons are shown, when we registered them as regular Windows filetype extensions in the registry, but in Visual Studio 2015 they do not.

    We tried now to register the icons over the XML-Tag <Icon> in the .vstemplate-file, which we installed in Visual Studio 2015, but the icons are still not shown in Solution Explorer.

    Are there any other methods, that the icons are shown ? Or could this be a bug in Visual Studio 2015?

    Thanks for your help Tom





    • Edited by TomGo1971 Wednesday, August 31, 2016 6:33 AM
    Thursday, August 25, 2016 9:26 AM

Answers

  • Hi TomGo1971,

    Where do you place your icon file? According to the settings you provided, you placed it in a folder under %USERPROFILE% path. However, this path may change when you login or run VS with different users. Can you try placing the icon file in a static path like "C:\xxx\xxx\File_indp.ico" and then updating the settings?

    • Marked as answer by TomGo1971 Monday, September 5, 2016 6:53 AM
    Monday, September 5, 2016 2:32 AM

All replies

  • Hi Tom,

    Welcome to the MSDN forum.

    According to your description, I tried to reproduce your behavior and I found the icon of the custom template is different with the icon that we set during the export templates progress, please have a look at the screenshot in VS 2015:

    Meanwhile, I also checked it in VS 2012, and the result is the same with VS 2015 like the following screenshot:

    It looks like the behavior between VS 2012 with VS 2015 are the same, if I have any misunderstanding about your issue, please feel free to let me know.

    >> In Visual Studio 2012 the icons are shown, when we registered them as regular Windows filetype extensions in the registry, but in Visual Studio 2015 they do not.

    Could you please share the screenshot of the icon or describe the detail steps to reproduce your result?

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, August 26, 2016 8:15 AM
    Moderator
  • Hi Weiwei

    Not the Icons in the Templates are the problem, these are correct, but the Icons in the Solution Explorer are the problem. We have also registered these files with the file extension in the Windows system, but only in Solution Explorer of VS2012 the icons are shown.

    In VS2015, the icons are not shown although the file type is registered in Windows:

    As you can see, the icons are also shown in the windows file explorer:



    But in the VS2015 Solution Explorer they are not shown.

    Kind regards,
    Thomas

    Wednesday, August 31, 2016 6:32 AM
  • Hi Tom,

    Thank you for your update and could you please provide the detail steps about how did you registered these file with file extension in Windows and I will try it on my local computer and see if the issue can reproduce or not.

    BTW, the VS 2012 and VS 2015 works side by side with the same computer or not? What’s the OS version?

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, September 1, 2016 7:14 AM
    Moderator
  • Hi Weiwei

    I've registered 2 file types.

    (inbp):

    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\.inbp]
    @="VisualStudio.inbp.14.0"
    
    [HKEY_CLASSES_ROOT\.inbp\OpenWithProgids]
    "VisualStudio.inbp.14.0"=""
    
    [HKEY_CLASSES_ROOT\VisualStudio.inbp.14.0]
    @="IN_BusiProc File"
    "AlwaysShowExt"="1"
    
    [HKEY_CLASSES_ROOT\VisualStudio.inbp.14.0\DefaultIcon]
    @="%USERPROFILE%\\AppData\\Local\\Microsoft\\VisualStudio\\14.0\\Extensions\\e2gj3kyr.kjm\\File_inbp.ico"
    
    [HKEY_CLASSES_ROOT\VisualStudio.inbp.14.0\shell]
    
    [HKEY_CLASSES_ROOT\VisualStudio.inbp.14.0\shell\Open]
    
    [HKEY_CLASSES_ROOT\VisualStudio.inbp.14.0\shell\Open\Command]
    @="\"C:\\Program Files (x86)\\Microsoft Visual Studio 14.0\\Common7\\IDE\\devenv.exe\" /dde"
    
    [HKEY_CLASSES_ROOT\VisualStudio.inbp.14.0\shell\Open\ddeexec]
    @="Open(\"%1\")"
    
    [HKEY_CLASSES_ROOT\VisualStudio.inbp.14.0\shell\Open\ddeexec\Application]
    @="VisualStudio.14.0"
    
    [HKEY_CLASSES_ROOT\VisualStudio.inbp.14.0\shell\Open\ddeexec\Topic]
    @="system"

    For the 2nd file type, I have added the regitry key "DefaultIcon" to give it another try (without success).

    (indp)

    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\.indp]
    @="VisualStudio.indp.14.0"
    
    [HKEY_CLASSES_ROOT\.indp\DefaultIcon]
    @="%USERPROFILE%\\AppData\\Local\\Microsoft\\VisualStudio\\14.0\\Extensions\\kmrvgubp.w4e\\File_indp.ico"
    
    [HKEY_CLASSES_ROOT\.indp\OpenWithProgids]
    "VisualStudio.indp.14.0"=""
    
    [HKEY_CLASSES_ROOT\VisualStudio.indp.14.0]
    @="IN_BusiProc_DataProcessor File"
    "AlwaysShowExt"="1"
    
    [HKEY_CLASSES_ROOT\VisualStudio.indp.14.0\DefaultIcon]
    @="%USERPROFILE%\\AppData\\Local\\Microsoft\\VisualStudio\\14.0\\Extensions\\kmrvgubp.w4e\\File_indp.ico"
    
    [HKEY_CLASSES_ROOT\VisualStudio.indp.14.0\shell]
    
    [HKEY_CLASSES_ROOT\VisualStudio.indp.14.0\shell\Open]
    
    [HKEY_CLASSES_ROOT\VisualStudio.indp.14.0\shell\Open\Command]
    @="\"C:\\Program Files (x86)\\Microsoft Visual Studio 14.0\\Common7\\IDE\\devenv.exe\" /dde"
    
    [HKEY_CLASSES_ROOT\VisualStudio.indp.14.0\shell\Open\ddeexec]
    @="Open(\"%1\")"
    
    [HKEY_CLASSES_ROOT\VisualStudio.indp.14.0\shell\Open\ddeexec\Application]
    @="VisualStudio.14.0"
    
    [HKEY_CLASSES_ROOT\VisualStudio.indp.14.0\shell\Open\ddeexec\Topic]
    @="system"

    I checked the paths under "DefaultIcon". They exists and the icon files are there.

    Kind regards,
    Tom

    Thursday, September 1, 2016 12:12 PM
  • Hi TomGo1971,

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thanks for your understanding!

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, September 5, 2016 2:12 AM
    Moderator
  • Hi TomGo1971,

    Where do you place your icon file? According to the settings you provided, you placed it in a folder under %USERPROFILE% path. However, this path may change when you login or run VS with different users. Can you try placing the icon file in a static path like "C:\xxx\xxx\File_indp.ico" and then updating the settings?

    • Marked as answer by TomGo1971 Monday, September 5, 2016 6:53 AM
    Monday, September 5, 2016 2:32 AM
  • Hi QuestionEddie

    Thanks for your tip. The placeholder %USERPROFILE% is the problem. If I use another file path and register it, the icons are shown in VS2015.

    As you say, VS2015 is started with another user account. VS2012 may started under my own account.

    I can also place the icons in a directory of my user account and register the absolute path (without %USERPROFILE%) in the registry. The icons are shown in the solution explorer of VS2012 as well as VS2015 then.

    Thanks four your hint.

    Tom

    Monday, September 5, 2016 6:53 AM