none
Plug and Play Device driver problem Windows Embedded 7 Pro RRS feed

  • Question

  • Hi All,

    We have encountered a strange problem with a Smart Card reader on WEP7. When you plug the device in the correct vendor drivers load and device works fine. However, when you reboot the Device comes up as unrecognized and you cannot manually install the drivers - OS says its not for this device.

    We have tried lots of things to resolve this, Checked conflicts, removed Vendor drivers and let MS generic driver replace them (This worked the same - fine at install then reboot unrecoignized.), turned off Windows Driver Installs off, Did the group policy Driver install etc.

    I have noticed when I look into the problem there is an error that occurs when rebooting but does not occur when you plug the device in. The error "firmware of the device did not give it the required resources. (Code 29)". There are no firmware updates available. All other drivers USB hubs etc. all upto date and Intel.

    Ideally, what would suit our purpose is to turn plug and play device install off just for that device and treat it like a static device. However, we need to be able to add other PnP devices.

    Is there a way of acheiving this? or any other ideas greatly appreciated.

    Thank you in advance

    Jim.

    Thursday, June 9, 2016 9:56 PM

All replies

  • Is the image a custom build with minimal packages selected? Or does this have all the packages to make it look like Windows 7?

    Do you have all the latest hotfixes and updates?

    Does the same thing happen with Windows 7 Pro or Ultimate?


    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Thursday, June 9, 2016 11:56 PM
    Moderator
  • Hi

    I have the same problem. Has this been solved. I'm using a Cherry TC1200 RFID scanner and a miFare card. The problem don't exist on standard windows 7 or 10. On the standard window version it install a Smart Card driver "Generic SmartCard" by Microsoft. Apprently this is missing on WES7.

    On standard windows it used Driver Node Strong Name:oem63.inf:Minidriver.NTamd64.6.1:Minidriver64_61_Install:1.0.0.3:scfilter\cid_804f0ca00000030603000100000000

    Have any solved this issue.?

    Thanks you in advance

    Ulrik

    Friday, January 11, 2019 9:56 AM
  • WES7 allows OEMs to create a custom build of the OS where they select feature packages to be included in the image. Some times missing driver packages can lead to driver installation issues.

    Did you build the WES7 image?


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Friday, January 11, 2019 5:18 PM
    Moderator