none
Unable to add new Enterprise Keywords or open "Tags & Notes" dialog RRS feed

  • Question

  • When adding a new Enterprise Keyword through the properties form everyone receives "Access Denied", even site collection administrators.  Existing Enterprise Keywords can be added to an item.  It is only new keywords that can't be added.  "Access Denied" is also displayed when you click on the "Tags & Notes" icon.  This was working fine.  This is limited to one web application.  No changes to security in Central Admin have been applied (that we know of).  However, we were having problems reading the metadata store after someone removed "NT AUTHORITY\authorized users" from a site collection yesterday.  This was fixed by re-adding "NT AUTHORITY\authorized users" to the site collection and to a hidden taxonomy cache list in the site collection with Read permissions which is the default setting after SP 2010 intallation.

    I have compared all web app settings in Central Admin with a working web app and they are identical.  I have compared SharePoint groups with a working site collection and they are identical.


    Rick

    Thursday, February 9, 2012 8:11 PM

All replies

  • Did you set the value of the default keyword location to YES in the connection to the managed metadata service?

    From MSDN:

    If no connection is specified as the default keyword location, users of sites in the Web application will be unable to create new enterprise keywords. If this is not what you want, set the value of the default keyword location to YES in the connection to the managed metadata service whose term store should contain the new enterprise keywords.


    SharePoint 2010

    Thursday, February 9, 2012 8:27 PM
  • Thank you for the reply.  The connection setting is still set to Yes.  This has been working for about a year and works fine for other web applications.


    Rick

    Thursday, February 9, 2012 9:43 PM