locked
System.Data.OracleClient requires Oracle client software version 8.1.7 or greater. RRS feed

  • Question

  • User-146687266 posted

    Hi all,

    Currenlty i am using asp .net 2.0 and oracle 10g.

    My current arhitechture look like this

    Server A - Oracle database 10g

    Server B - Web application and Oracle 10 g client

     I am using System.Data.OracleClient for database connection. It work fine when i doing development. But after i published and deployed in IIS. i get System.Data.OracleClient requires Oracle client software version 8.1.7 or greater. I also try to search from the internet through that error message but the solution that i get seems like not work. I am stucks, Please help

    Thanks a million Help

    Thursday, November 16, 2006 2:48 AM

All replies

  • User-68991420 posted

    Hi,

    http://www.oracle.com/technology/software/tech/windows/odpnet/index.html

    it requires Oracle10g Release 2 ODAC 10.2.0.2.20  to be installed on the Application server. Try it out .

     

    Mahboob

     

     

     

    Monday, December 4, 2006 11:26 PM
  • User-186692512 posted

    There is known bug with Oracle installer which does not setup rights on folders as expected, so IUSR_ or ASPNET machine user can't access appropriate Oracle Client DLL's.

    Try to add Everyone / Read for Oracle home and all subfolders and restart IIS - this should solve problem. 

     

    Tuesday, December 5, 2006 1:03 AM
  • User-581286394 posted
    System.Exception: System.Data.OracleClient requires Oracle client software version 8.1.7 or greater.
    at System.Data.OracleClient.OCI.DetermineClientVersio n()
    at System.Data.OracleClient.OracleInternalConnection. OpenOnLocalTransaction(String userName, String password, String serverName, Boolean integratedSecurity, Boolean unicode, Boolean omitOracleConnectionName)
    at System.Data.OracleClient.OracleInternalConnection. .ctor(OracleConnectionString connectionOptions)
    at System.Data.OracleClient.OracleConnectionFactory.C reateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
    at System.Data.ProviderBase.DbConnectionFactory.Creat ePooledConnection(DbConnection owningConnection, DbConnectionPool pool, DbConnectionOptions options)
    at System.Data.ProviderBase.DbConnectionPool.CreateOb ject(DbConnection owningObject)
    at System.Data.ProviderBase.DbConnectionPool.UserCrea teRequest(DbConnection owningObject)
    at System.Data.ProviderBase.DbConnectionPool.GetConne ction(DbConnection owningObject)
    at System.Data.ProviderBase.DbConnectionFactory.GetCo nnection(DbConnection owningConnection)
    at System.Data.ProviderBase.DbConnectionClosed.OpenCo nnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
    at System.Data.OracleClient.OracleConnection.Open()
    at QuoteService.connStr() in c:\Inetpub\wwwroot\FirstApplBasu\App_Code\QuoteSer vice.cs:line 109
    at QuoteService.InsertRec() in c:\Inetpub\wwwroot\FirstApplBasu\App_Code\QuoteSer vice.cs:line 118

    To fix the above problem i have tried the Authenticated Users group privilege to the Oracle Home directory.

    * Log on to Windwos as a user with Administrator privileges.
    * Start Window Explorer and navigate to the ORACLE_HOME folder.
    * Choose properties on the ORACLE_HOME folder.
    * Click the “Security” tab of the “Properties” window.
    * Click on “Authenticated Users” item in the “Name” list.
    * Uncheck the “Read and Execute” box in the “Permissions” list under the “Allow” column.
    * Re-check the “Read and Execute” box under the “Allow” column
    * Click the “Advanced” button and in the “Permission Entries” verify that “Authenticated Users” are listed with permission = “Read & Execute”, and Apply To = “This folder, subfolders and files”. If not, edit that line and make sure that “Apply To” drop-down box is set to “This folder, subfolders and files”. This should already be set properly but it is important that you verify it.
    * Click the “Ok” button until you close out all of the security properties windows. The cursor may present the hour glass for a few seconds as it applies the permissions you just changed to all subfolders and files.
    * Reboot, to assure that the changes have taken effect.


    after trying them also no use im getting same error could any one help me regarding this

    in advance thanks,
    Basaveswari
    Wednesday, April 18, 2007 8:12 AM
  • User-1220424958 posted

    To either of you still having the issue, are you using mixed clients (eg: 9i / 10g), or are you purely 10g?

    ....and what IIS versions are you working with?

    ....Have you installed any Oracle-specific items that deal with data access recently?

    ... .Oh and do you have multiple Oracle Homes defined?

    Wednesday, May 2, 2007 5:29 PM
  • User-1669052419 posted
    I was having the same issue. My problem was that the permissions were not propagating down to the bin directory. I had to explicity grant read and execute privilages to the ASPNet user on the bin directory, not just the oracle home directory.
    Tuesday, May 8, 2007 12:07 PM
  • User-2098386135 posted

    I was having the same problem with a few projects and no matter how many permissions I changed I still got the error. I had to eventually recreate my VS websites/projects from scratch.

    Friday, June 1, 2007 5:23 PM
  • User-1658453331 posted
    restart iis
    Tuesday, June 19, 2007 5:42 AM
  • User-1759563391 posted

    try ODPdotNet as db driver instead of other db drivers

    Wednesday, October 17, 2007 10:10 PM
  • User1652833153 posted

    Hi Yewmeng,

    I am facing the similar problem as you mentioned in the above. I am using System.Data.OracleClient for database connection. I have installed Oracle 10.1.0 client software and application is working fine on my development machine. After deployed, I am getting error message System.Data.OracleClient requires Oracle client software version 8.1.7 or greater. I gave Internet guest account (IUSR_) and Everyone read and execute permissions on Oracle folder. Still the same error. Appreciate if you can tell me how did you solve this issue.

     Thanks a lot, Shailaja

    Tuesday, May 20, 2008 7:05 PM
  • User416102919 posted

    hello every body, just i need to know how i will go to this path "* Start Window Explorer and navigate to the ORACLE_HOME folder. " cause on my Machine there is no Oracle_home can any one give me the path.

    that means i opened window explorer then what i will type ....

    thanks

    Wednesday, September 24, 2008 5:35 AM
  • User416102919 posted

    thanks guys i found it its from "folder option" the problem with simple file sharing it must be unchecked

     

    thanks alot

    Wednesday, September 24, 2008 5:45 AM
  • User1952181681 posted

    Hi, I had the same problem and solved it by changing the security setting as described but with one further step. On the Advanced tab check Replace permission entries on all child objects with entries shown here that apply to child objects. Then reset iis. YAY it worked at last.

     

    Madre

    Thursday, October 30, 2008 11:07 PM
  • User894665731 posted

    Hello

    I am facing great problem with Oracle and ASP.Net tried a lot but could not sort out the problem

    anyways just want to know that On my Pc I haev installed Oracle10g and Asp.Net 2.0  and Windows Xp

    I am able to connect to Oracle Server and have sysDba rights.

    Should I have to give permission on my PC or on server.

    I tried a lot on giving permission to OraNT Folder, but there is no Security as its only on server.

    So Do i have to give Permissions on Oracle Server.

    and also Do I have to Install IIS on Oracle Server.

     

    Please Reply as soon as possible

    Thanks in Advance.

     

    Friday, April 10, 2009 6:29 AM
  • User-1322853079 posted

    Hi All,

     For furthere reference which would help others

     http://forums.asp.net/t/1197847.aspx

     

    Thanks

    Suresh Kumar Goudampally

     

    Friday, April 10, 2009 7:09 AM
  • User894665731 posted

    Does ASP.net 2.0 support connectivity to Oracle 8.0 version ?

    PLz Reply

    Saturday, April 11, 2009 7:12 AM
  • User-1322853079 posted

    It supports ,

    Use System.Data.OracleClient  to connect to oracle 8.0

     

    Thanks

    Suresh Kumar Goudampally

    Monday, April 13, 2009 1:09 AM
  • User894665731 posted

    Hi

    thanks for the reply

    I already tried giving Read&Execute permission to Authenticated Users
    Group and Internet Users on the Oracle Server  and reboot the server .

    Uninstall and Installed the Oracle on my PC. still problem exists 

    But that did't work either.

    Please its urgent.

    I have just hanged up with this problem.

    Please please what to do ?


     

    Monday, April 13, 2009 11:45 PM
  • User894665731 posted

    Do I have to Install any Component or dll on the server for Oracle to work with Asp.net

    Is IIS necessary to present on server .

    Tuesday, April 14, 2009 12:12 AM
  • User-186692512 posted

     In order to work with Oracle in ASP.NET, you need to:

    1. Install Oracle on machine which will be database server

    That is it - nothing more on this server

    On machine which will run your application (if this is not same as machine (1)) you need to install:

    2.1 IIS (if it is not installed already)

    2.2 .Net Framework of appropriate version (2.0, 3.0, 3.5 or all) - version depends on which Framework you develop application

    2.3 Appropriate Oracle client with Oracle OLEDB layer (usualy called Oracle Data Access Components - ODAC)

    You also need to install (2.3) on your development machine where you installed Visual Studio.

    Hope this helps.

    Tuesday, April 14, 2009 2:14 AM
  • User364663285 posted

    Vsurana,
    Are you able to connect to your Oracle DB using your Orale client. Try to use 10g client instead.

    Tuesday, April 14, 2009 3:01 AM
  • User-1090742494 posted

    Thank you Dejan. 

    This fixed the issue for me.

    I am using Oracle 10g, with WCF service.

    Wednesday, April 22, 2009 1:34 PM
  • User894665731 posted

    thanks Dejan

    That Solved my problem really thanks.

     Now its creating other problem

    I am trying to connect Oracle 10g with ASp.net Crystal Reports but its not connecting and showing error "Tns could not resolve ..."

    But it is connecting to Forms and all ,other all things are working fine

    Please let me know how can I connect Crystal reports with Oracle

    Wednesday, May 27, 2009 12:21 AM
  • User364663285 posted

    You can check if your ODBC is working fine against your Oracle DB.

    Wednesday, May 27, 2009 12:35 AM
  • User-639975331 posted

    To others out there who are looking for the solution to System.Data.OracleClient requires Oracle client software version 8.1.7 or greater. , i tried various solution i found on google including changing user permissions, reinstalling oracle 10g, and other stuff.. but at the end I found out the solution myself by looking at the difference between my two computers (one is working, the other had this error)

    if you tried other methods and still can't fix this problem, the easy but often overlooked problem that could have caused this error is:

    Go to Start > Control Panels > System > Advanced tab > Environment Variables

    look under System Variables.. There's a variable called 'Path' .. double click on it to edit it. See if there's a path to your oracle_home directory's Bin folder.. if it's not, congratulations, you just have to manually add in the path and the error will be gone :)

    For example my oracle_home directory is C:\oracle\10.2\ , the bin folder will be C:\oracle\10.2\bin\

    So what I do is I edit the Path variable and add in C:\oracle\10.2\bin; at the very front of the line of the variable value column (ps: the semicolon seperates each variables so that they can all be in one line)

    Viola, problem solved for my case.. i don't know why on one of my computer oracle installation automatically modifies the Path variable but on the other computer it doesn't... took me 2 weeks to search for the solution in google but couldn't find anyone that mentions this.

    Cheers.

    Monday, September 7, 2009 4:50 AM
  • User556731785 posted

    We resolved the problem as follows:

    1- defined ORACLE_HOME environment parameter

    2-Installed ODAC

    3- reboot the machine.


    It did not work if you did not reboot, I donot know why.


    Sincerely,

    Derya.

    Monday, September 7, 2009 5:02 AM
  • User1062635582 posted

    Is it possible to embed the "Oracle Instant Client" into the web application (let's say as a reference in the /bin folder) so we would not need to install the full client into the web server?

    Thanks

    Tuesday, September 22, 2009 10:14 AM
  • User-946444436 posted

    This link was perfect. I was having the same issue, Windows 7 + VS2008 + Oracle 10G Client combination on my machine. Error on trying to access oracle I got this error "System.Data.OracleClient requires Oracle client software version 8.1.7 or greater."

     

    The fix was to visit http://www.oracle.com/technology/software/tech/windows/odpnet/utilsoft.html and download/setup

    ODAC1020221.exe 206 MB (216,841,603 bytes)

     

    Thanks a lot.  

    ~A

    Monday, October 26, 2009 12:29 PM
  • User655545874 posted

    I had the same problème, I solved it by installing Oracle Client "as an administrator".

    Tuesday, September 4, 2012 5:39 AM