locked
ASP.NET Web Configuration Tool and VS2013 RRS feed

  • Question

  • User652650364 posted

    Hello to everyone! I am trying to connect with Web Admin Tools doing exactly what is saying this article: http://stackoverflow.com/questions/20541680/visual-studio-2013-and-asp-net-web-configuration-tool but my browser throws the above error.

    Server Error in '/WebAdmin' Application.

    Compilation Error
    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: CS0122: 'System.Configuration.StringUtil' is inaccessible due to its protection level

    Source Error:
    Line 987:
    Line 988: // Put together some unique app id
    Line 989: string appId = StringUtil.GetNonRandomizedHashCode(String.Concat(appPath, appPhysPath)).ToString("x", CultureInfo.InvariantCulture);
    Line 990:
    Line 991:

    Source File: c:\Windows\Microsoft.NET\Framework64\v4.0.30319\ASP.NETWebAdminFiles\App_Code\WebAdminPage.cs Line: 989


    Any idea what happening?
    Thank you!

    Thursday, July 16, 2015 9:40 AM

Answers

  • User-718146471 posted

    Typo on part of the article, your command should be like this:

    iisexpress.exe /path:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles" /vpath:”/ASP.NETWebAdminFiles” /port:[port] /clr: 4.0 /ntlm

    Long paths should always be surrounded by double quotes.  The other possibility is you do not have that path.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, July 24, 2015 1:19 PM

All replies

  • User-718146471 posted

    You could try this instead (from http://blogs.msdn.com/b/webdev/archive/2013/08/19/asp-net-web-configuration-tool-missing-in-visual-studio-2013.aspx):

    As many of you have noticed, the option to select “ASP.Net Web Configuration Manager” is no longer in Visual Studio 2013 Preview. This is due to the removal of the Visual Studio Development Server (or Cassini) from the product. However, we understand that many people have gotten used to using the Tool, and so here are the steps by which you can still run the manager. Note that these instructions only work for sites running on the .NET Framework 4.0 and above.

    1. Open the Command Prompt (not as administrator)
    2. Navigate to the folder where IIS Express is installed on your machine.
    3. In the command line spin up a IISExpress site with the following prompt: “iisexpress.exe /path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:”/ASP.NETWebAdminFiles” /port:[port] /clr: 4.0 /ntlm” using the following values for the [param]:
      1. [port] – any port you have free in IISExpress (I use 8082 in the example below)
    4. This should launch an IISExpress instance of the Configuration Manager Site

    5. Open your browser
    6. In the URL enter the following “http://localhost:8082/asp.netwebadminfiles/default.aspx?applicationPhysicalPath=[appPath]&applicationUrl=/” substituting the [appPath] with the absolute path to the Visual Studio Project folder with the solution file in it.

    Congratulations, you now have your ASP.net Web Site Administration Tool running as before.

    Thursday, July 16, 2015 10:06 AM
  • User281315223 posted

    string appId = StringUtil.GetNonRandomizedHashCode(String.Concat(appPath, appPhysPath)).ToString("x", CultureInfo.InvariantCulture);

    Is the code mentioned above your actual code? As it sounds like this might just be an issue regarding the protection level of your actual StringUtil class. Is it defined using a non-restrictive access modifier like "public" or "protected" or is it defined using something like static?

    It doesn't sound like the actual error relates directly to the Web Configuration Tool itself.

    Thursday, July 16, 2015 10:24 AM
  • User652650364 posted

    in Command Prompt, when i enter the command says "The following switch requires a value 'path'." What's going wrong?

    Friday, July 17, 2015 3:53 AM
  • User-718146471 posted

    Typo on part of the article, your command should be like this:

    iisexpress.exe /path:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles" /vpath:”/ASP.NETWebAdminFiles” /port:[port] /clr: 4.0 /ntlm

    Long paths should always be surrounded by double quotes.  The other possibility is you do not have that path.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, July 24, 2015 1:19 PM