locked
Blend 2 opens VS 2005 instead of VS 2008 RRS feed

  • Question

  • When I double click to create event code, Blend 2 trys to open vs2005 instead of vs2008.  I figure it is some kind of Assoc thing, but not sure how to fix. Any ideas?  Look forward to using more blend.
    Sunday, May 18, 2008 1:33 AM

Answers

  • If the setting Options > Event Handlers > Visual Studio if available is checked then Blend will automate Visual Studio if that product is installed and currently automatable. Blend is just a client of VS’s automation model so if you can automate VS then Blend should be able to. You can learn more about this here: http://msdn2.microsoft.com/en-us/library/68shb4dw(VS.80).aspx

     

    So what you can do here is
    1. Update the registry: HKEY_CLASSES_ROOT\VisualStudio.DTE
    a) set the default value of HKEY_CLASSES_ROOT\VisualStudio.DTE as {1A5AC6AE-7B95-478C-B422-0E994FD727D6} which should be same with the default value of HKEY_CLASSES_ROOT\VisualStudio.DTE.9.0\CLSID
    .
    b) set the default value of HKEY_CLASSES_ROOT\VisualStudio.DTE\CurVer as VisualStudio.DTE.9.0.

    OR
    2. Reinstall or repair Visual Studio 2008

    Thursday, June 5, 2008 9:52 AM

All replies

  • I have experienced this.  Anyone have any solutions?  Thanks.
    Tuesday, June 3, 2008 6:03 PM
  • If the setting Options > Event Handlers > Visual Studio if available is checked then Blend will automate Visual Studio if that product is installed and currently automatable. Blend is just a client of VS’s automation model so if you can automate VS then Blend should be able to. You can learn more about this here: http://msdn2.microsoft.com/en-us/library/68shb4dw(VS.80).aspx

     

    So what you can do here is
    1. Update the registry: HKEY_CLASSES_ROOT\VisualStudio.DTE
    a) set the default value of HKEY_CLASSES_ROOT\VisualStudio.DTE as {1A5AC6AE-7B95-478C-B422-0E994FD727D6} which should be same with the default value of HKEY_CLASSES_ROOT\VisualStudio.DTE.9.0\CLSID
    .
    b) set the default value of HKEY_CLASSES_ROOT\VisualStudio.DTE\CurVer as VisualStudio.DTE.9.0.

    OR
    2. Reinstall or repair Visual Studio 2008

    Thursday, June 5, 2008 9:52 AM
  • I must be a developer (or so I would hope so :>) cause I jumped right into your solution before reading your "OR.....reinstall/repair" option.  DO!  Hey, I didn't say I was a senior developer (read then develop). :>

    Anyways, that worked like a charm! :>  Thank you very much! :>  I would hope the release version will make that registry change for me upon install.
    Thursday, June 5, 2008 1:40 PM