locked
Digitizer pen is being picked up as a mouse RRS feed

  • Question

  • I'm using the Tablet PC SDK v1.7 and having an issue distinguishing between the digitizer pen and the mouse when it comes to CursorDown events and the like.  I have an external usb digitizer (Aiptek T-8000U) with the Hyper Pen Usb drivers.  I have found several examples on how to distinguish between the two, including used the tablets collection, and checking the results of a call to GetMessageExtraInfo(), but both seem to imply that the pen is no different than the mouse.  Is this a problem with the sdk, or could it be an issue with the digitizer drivers?

    Thanks,

    Dustin

    Monday, February 19, 2007 5:25 PM

Answers

  • Hi Dustin:

    This is usually a problem with the digitizer drivers. Most external digitizers send mouse messages in order to maintain compatibility with Windows. I would contact the digitizer manufacturer and ask if they have a HID driver that supports Tablet PC functionality.

    Regards,
     - Mark Hopkins (MSFT)

    Saturday, February 24, 2007 12:40 AM
    Moderator

All replies

  • Hi Dustin:

    This is usually a problem with the digitizer drivers. Most external digitizers send mouse messages in order to maintain compatibility with Windows. I would contact the digitizer manufacturer and ask if they have a HID driver that supports Tablet PC functionality.

    Regards,
     - Mark Hopkins (MSFT)

    Saturday, February 24, 2007 12:40 AM
    Moderator
  • Mark,

    Thanks for the information.  I have an email out with the manufacturer support, but no reply as of yet.  I want to say that the driver that it installed is an HID driver, but I'm not positive.  In the mean time I finally figured out how to use the very cryptic wintab api and have been successful in receiving only the packets with the pen tip events.  What seemed like a simple task two weeks ago turned out to be a nightmare.

    Thanks Again,

    Dustin

    Saturday, February 24, 2007 2:28 AM
  • I'm also having the same issue as well. I'm using a aiptek t-8000u and I already sent the vendor a email 4 days ago, but still no respond over the matter ; ;. Looking online is a pain in the butt as well. I keep getting the same results.
    Monday, June 18, 2007 11:47 PM
  • http://www.aiptek.com/drivers.htm#hp8u

     

     

    thats where you can find the drivers for windows vista. took me a while to find it.. but it works ^^>

    Wednesday, June 20, 2007 6:17 AM