none
Azure Data Lake Store Gen2 API and Blob storage interoperability

    Question

  • Hi Folks,

    I have been trying to use the Golang SDK sample to write objects to a Gen2 Data Lake Storage account but keep getting the following error message:

    Description=Blob API is not yet supported for hierarchical namespace accounts.
    RequestId:f271bf07-001e-0043-7e03-d9e5c2000000

    I understand the sample is trying to use blob API and did some searching about the API interoperability and found somewhere that the APIs were supposed to be interoperable after GA. I guess the timelines have moved a little bit, so, was wondering if this issue is going to be addressed soon? We could call the ADLS Gen2 API ourselves otherwise.

    Thanks

    Tuesday, March 12, 2019 6:43 PM

All replies