none
synchronizing web content RRS feed

  • Question

  • I am in the process of cleaning up old websites. If I am in Web Site/View Folder Contents where I can see both the local and remote sites and I am in a sub-directory what happens if I pick the radio button "local to remote" does it just publish the sub-directory, or does it try to publish the entire web? Sometimes I want to click the arrow to send from local to remote. It appears to upload, but the remote page is not updated.

    Or, if I am working on a page--then save it. I highlight that file in my Folder List, right click and choose publish. It will take more time  than it should and put up an error message "Could not Find Web server at... (website) port 21. If I click ok and try again  it goes right up.

    But...it doesn't always send the changes up.

    I have Expression Web 12.0.6211 (I am not sure if I have Super Preview...?)

    Any recommendations?


    robkir

    Thursday, September 13, 2012 3:57 PM

Answers

  • Right. I had already mentioned the IE setting, but it doesn't hurt to mention it again. It might be that EW2 had the same method of accessing the passive setting, since it still had the "Site" stuff under the File menu, but I don't have that version installed on this laptop.

    robkir, something you might consider is upgrading to EW4. It is far, far more capable than EW1, with many more features, including SuperPreview, and in addition to EW, you get a decent vector/raster graphics editor in Expression Design, and video capture/encoding in Expression Encoder, all for the upgrade price of $79, almost half what the original EW alone cost. Worth considering...  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Marked as answer by robkir Monday, September 17, 2012 2:33 PM
    Saturday, September 15, 2012 8:51 PM

All replies

  • If the file doesn't appear immediately, try clicking in the remote folder list and press F5 (refresh) this might make it appear, or maybe it is publishing to the wrong folder.  e.g. you might have your root (home) folder open on local site, but a folder called /images open on the remote, so files you expect to go to the root folder are published to /images instead.

    Are you connecting by FTP or HTTP (server extensions)?

    With FPSE, it appears the local file will publish to the correct remote file/folder, regardless if you have that folder 'active' on the remote site.  If a file stored in '/images' on the local site, should transfer correctly to the same folder '/images' on the remote site.

    In my experience, for FTP, you need to manually make sure that the same folder is active on local and remote sites.  This is also the case with any other standard FTP program.

    I'm not sure about your "could not find web server...." errors, but it is probably not something caused by EW; more likely it's your internet connection related to the FTP server at your hosting company.  Double-check the log-on credentials and other settings, such as using FTP "Passive" mode if not already on etc. 

    Come to think of it, you also mention the upload takes a while, so the "couldn't find server" could be a "time-out" message, which is a setting set by your hosting server administrator.  What kind of files are you uploading?  You could probably optimise images so they are minimal file size (in terms of KB) in Irfanview or similar image editor.

    If you search the forum here, you will find a host of solutions surrounding FTP connection issues, for example, the search results here


    Andrew M


    http://www.murraywebs.com

    "Nothing spoils numbers faster than arithmetic!"
    -- Peppermint Patty (Peanuts, Charles M. Schulz)



    • Edited by AndrewOZ1 Thursday, September 13, 2012 10:44 PM
    Thursday, September 13, 2012 10:37 PM
  • Are you connecting by FTP or HTTP (server extensions)?


    Hi Andrew,

    I am connected via FTP. I think you are right about the hosting company being the root source of publishing problems. I am contacting them. By the way, where in EW does one change Passive to Active? I looked through all the menus (except...probably, the one that let's you make the change) and could not locate it.

    Thanks for your help.

    robkir


    robkir

    Friday, September 14, 2012 1:42 PM
  • Site > Publishing Settings, select the connection you want to edit and use the edit button. In the resulting Connection Settings dialog box the last checkbox on the page is "Use Passive FTP". Check it for Passive, leave it empty for Active FTP.

    Free Expression Web Tutorials
    For an Expression Web forum with without the posting issues try expressionwebforum.com

    Friday, September 14, 2012 6:56 PM
  • If the file doesn't appear immediately, try clicking in the remote folder list and press F5 (refresh) this might make it appear, or maybe it is publishing to the wrong folder.  e.g. you might have your root (home) folder open on local site, but a folder called /images open on the remote, so files you expect to go to the root folder are published to /images instead.

    Not so, Andrew. EW presumes that the folder you set up in the Directory field of your site's Connection Settings dialog (see below) is the base folder, and that it has a one to one correspondence to the local base folder (and usually this is set up so that this base folder is the site root in both cases). Therefore, when you use any of the "Publish..." commands on the "Site" dropdown menu, or the blue arrows in the center with files highlighted, the files will be properly published to the respective directories, regardless of what is visible in the respective folder views. The only way I have found to publish to the wrong directory is to drag and drop from local to remote, with the wrong folder visible. In such a case, EW presumes that you know what the hell you are doing, and transfers the file(s) as directed.

    Please refrain from making incorrect, misleading statements without testing. Novices come here expecting that what we tell them is correct, and can become confused when what they observe is not congruent with what they have been told. This is not the first time you have done this, nor the first time you have been asked not to do so. Please comply.

    To the OP, you can set the passive/active switch in your Connection Settings dialog, shown below.

    It's a binary setting; if passive is not selected, active is enabled by default. Depending upon your OS and your IE version, you may have to also set this in IE's "Tools|Internet Options|Advanced|Use Passive FTP." IIRC, later versions don't have this issue, but if you're on XP with IE6 to IE8, you may need to set it.

    Also note that since EW transfers the files to the correct directory, even if you are not viewing that directory in the remote folder pane, the files may actually be transferring after all, but you won't see them until you move the remote view to the correct folder. Have you checked that?

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Friday, September 14, 2012 7:14 PM
  • I finally found the FTP Connection mod hidden under Application Options/FTP and it is set to passive. The more I think about it, the more it look like this is a problem between my local server and my hosting company. Particularly when you consider that if I establish my FTP connection and immediately upload files I have no problems.  But if I establish a FTP connection, work on a page for, say ten minutes, then try to publish that page, it will more often than not fail.

    I appreciate the input. Thanks for the help.

    robkir



    robkir

    Saturday, September 15, 2012 4:04 AM
  • In Application Options the setting there is global for all websites. If you use the checkbox in Publishing Settings that Scott and I gave you instructions for it is for that website only. Unless you only work on one site I'd suggest using the method that is per site instead of global.

    Free Expression Web Tutorials
    For an Expression Web forum with without the posting issues try expressionwebforum.com

    Saturday, September 15, 2012 12:32 PM
  • In Application Options the setting there is global for all websites. If you use the checkbox in Publishing Settings that Scott and I gave you instructions for it is for that website only. Unless you only work on one site I'd suggest using the method that is per site instead of global.

    Thanks for the follow up. I did try to find your original suggestion of "Site > Publishing Settings" but I have a different menu: Site > Site Settings. It shows this:

    The only other screen I can find that appears to relate is Remote Web Site Properties.


    I went through each tab and each button, but could not find anything I could see that related to the passive issue.

    Either that...or there is something obvious that I can't see (and...it wouldn't be the first time).


    robkir


    • Edited by robkir Monday, September 17, 2012 2:28 PM update screen grabs to eliminate web destinations
    Saturday, September 15, 2012 1:57 PM
  • Hmm... I think that this might be a prime example of how versions change over time. This is what Site Settings looks like in current versions:

    In that case, you would select the Publishing Destination (blurred out above), then click "Edit," which would launch the Connection Settings dialog I showed in my last post. It appears that you have EW1, or Expression Web Design, as it was called then. That's the only version that I have not used, so I'll have to let Cheryl, Pat, or one of the others who go back that far tell you how to get there.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Saturday, September 15, 2012 5:48 PM
  • In EW 2 File > Publish Site > Remote Web Site

    Use Passive FTP is the last item.

    I believe this is for EW1

    To publish a Web site by using FTP, change the Internet Explorer connection mode from passive to active. To do this, follow these steps:
      • In Internet Explorer, click Internet Options on the Tools menu.
      • In the Internet Options dialog box, click to clear the Use Passive FTP (for firewall and DSL modem compatibility) box on the Advanced tab under Settings.

        Note If the Use Passive FTP (for firewall and DSL modem compatibility) check box is already selected, click to clear the box. If the Use Passive FTP (for firewall and DSL modem compatibility) check box is cleared, click to select it. This is to toggle the FTP setting.

    pat


    Pat Geary - Microsoft MVP

    Expression  Web Tutorials & Templates | Expression Web Blog | Migrating from FrontPage to Expression
     - Free EW Community Toolbar - Free Site Templates


    • Edited by Pat Geary Saturday, September 15, 2012 7:35 PM
    Saturday, September 15, 2012 7:32 PM
  • Right. I had already mentioned the IE setting, but it doesn't hurt to mention it again. It might be that EW2 had the same method of accessing the passive setting, since it still had the "Site" stuff under the File menu, but I don't have that version installed on this laptop.

    robkir, something you might consider is upgrading to EW4. It is far, far more capable than EW1, with many more features, including SuperPreview, and in addition to EW, you get a decent vector/raster graphics editor in Expression Design, and video capture/encoding in Expression Encoder, all for the upgrade price of $79, almost half what the original EW alone cost. Worth considering...  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Marked as answer by robkir Monday, September 17, 2012 2:33 PM
    Saturday, September 15, 2012 8:51 PM
  • I really appreciate all the thoughtful explanations and information. But rather than tinker, I think I'll go with Scott's recommendation and upgrade. I've traditionally used the rule of thumb, if it ain't broke, don't fix it. Well...my version appears to be heading towards the broke side of the equation. For $79 it sounds like a bargain.

    Thanks,

    robkir


    robkir

    Sunday, September 16, 2012 1:16 PM
  • An excellent choice. I don't think you will be sorry as there are many improvements.

    pat


    Pat Geary - Microsoft MVP

    Expression  Web Tutorials & Templates | Expression Web Blog | Migrating from FrontPage to Expression
     - Free EW Community Toolbar - Free Site Templates

    Sunday, September 16, 2012 5:02 PM
  • And you can have both versions installed on your system, so that may ease your transition. I have EW 2, 3, and 4 installed (mostly just for reference when someone asks an interface-specific question here in the forum). 

    It's not the heat, it's the stupidity.

    Sunday, September 16, 2012 5:12 PM
  • And you can have both versions installed on your system, so that may ease your transition.

    that's good!

    Thanks for the guidance. I appreciate it.

    robkir


    robkir

    Monday, September 17, 2012 2:07 PM
  • An excellent choice. I don't think you will be sorry as there are many improvements.

    pat


    Pat Geary - Microsoft MVP

    Expression  Web Tutorials & Templates | Expression Web Blog | Migrating from FrontPage to Expression
     - Free EW Community Toolbar - Free Site Templates

    Well...I went to order the upgrade and find myself a bit confused. My current version's box says Microsoft Expression Web (I upgraded from FrontPage somewhere around 2006).  So do I want the Expression Studio 4 Web professional Upgrade? Sometimes, if one does not upgrade regularly, old versions need to be incrementally upgraded. Is that the case here?Am I smarter just buying the latest version and is thatStudio 4 Professional? 

    Thanks


    robkir

    Monday, September 17, 2012 8:18 PM
  • Yes, you should order Expression Studio Web Professional 4. That link goes to Amazon, where you will find it for $61.87, with free shipping. That is the version which includes Expression Design and Expression Encoder. You do not need the Ultimate version, which includes Expression Blend + Sketchflow, and Encoder Pro, neither of which you need, and which raises the price to $319.99.

    Any prior version is a qualifier for the upgrade price, so you're good there, and the versions are completely independent and can be installed side by side. I have versions 2, 3, and 4 installed on one machine, and can run them independently or simultaneously. Go get that boxed version, install it, and enjoy yourself some EW goodness!  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Monday, September 17, 2012 8:48 PM
  • Order it today...thanks Scott.

    robkir


    robkir

    Monday, September 17, 2012 9:16 PM