locked
Intermittant Wireless Connection Issues

    Question

  • HP Slate 500

    Developer Preview x86

    ------------------

    Sometimes when I boot and login the Developer Preview will not connect to any WiFi. It simply tells me it cannot connect and suggests I run the connection troubleshooting which detects a problem with the access point and fails. Sometimes a re-login works, sometimes multiple reboots are required.


    Now this occurs with my home Router, University Wireless, my HTC Trophy WiFI Tethering and the free WiFi at Christchurch Airport. As it can connect perfectly sometimes it indicates to me an issue with the device, not those routers (especially since other devices connect happily).

     

    I have the official drivers installed from the HP support site. Now I installed those drivers using Win7 Compatibility mode, but the default Win8 drivers had the same issue. Note that the Windows 7 installation that was previously on the Slate had never experienced this issue.

     

    -------------------------

     

    So now that my explanation is over, does anyone have a clue as to WTH is going on or any advice on how to begin troubleshooting?

     

    Thanks,

     

    Chris

    Tuesday, December 6, 2011 1:52 AM

Answers

All replies

  • This is pre-Beta version of Windows 8 and drivers are still under development by manufacturer and many improvements are in progress. Since it is compatibility issue I suggest follow steps on:

    http://social.technet.microsoft.com/wiki/contents/articles/troubleshoot-compatibility-issues-in-windows-8-developer-preview.aspx

    Also if this issue happens try turn off your Wireless for a while and then turn it on again and see if it resolved the problem.

    Tuesday, December 6, 2011 9:06 AM
  • Sometimes a firmware upgrade on the router will help. See if there is an upgrade for your home router firmware and see if that helps.
    This will help in trouble shooting. Still is most likely compatibility issues with router/drivers.
    Marilyn
    Tuesday, December 6, 2011 8:34 PM
    Moderator
  • University Router: Up to date

    HTC Trophy: Up to date

    Home: Up to date

    Unable to comment on CHCH Airport routers.

    -----


    That troubleshooting page was useless sorry, it is for programs and programs are not the issue. The Wireless Adaptor is. Now this problem does not occur on other HP Slate 500 devices so the drivers are theoretically sound. I tried uninstalling the driver and reinstalling it to no avail


    Is there no way to minidump the WiFi history so we can see what the problem is?
    • Edited by Crucias Tuesday, December 6, 2011 9:09 PM
    Tuesday, December 6, 2011 9:06 PM
  • You can go to an elevated command prompt and try the following to see if it will give you the information you need.

    Use the Netsh command and then set up tracing for the wireless network.

    netsh wlan set tracing enabled=yes

    set tracing enabled={yes|no} [[mode=]{persistent|nonpersistent}]

    The enabled parameter is required. The mode parameter is optional. If the mode parameter is set to persistent, trace logs are always generated until the enabled parameter is set to no.

    The default value for the mode parameter is nonpersistent.

    Another setting you might want to look at is: netsh wlan show settings

    Let us know if this helps in troubleshooting.


    Marilyn
    Tuesday, December 6, 2011 10:10 PM
    Moderator
  • Hey Chris,

     

    You may also want to try using the solution found by MaximumBackpack in the thread linked below to see if that allows you to connect to wireless networks without having to restart multiple times:
    http://social.msdn.microsoft.com/Forums/en-US/windowsdeveloperpreviewgeneral/thread/79b4d1e4-1bf7-46d1-a1bb-628a471bd8fc#491bbf02-c358-4954-a2aa-8aab911de077


    Steven
    Monday, December 12, 2011 6:43 PM
    Moderator
  • that tried it alright. What a stupid error at least it's been found  before beta
    Tuesday, December 13, 2011 1:35 AM
  • Hey Chris,

     

    Thanks for the update and I'm glad to have helped!


    Steven
    Tuesday, December 13, 2011 1:46 AM
    Moderator