locked
Having some problems when I publish my metro-style app RRS feed

  • Question

  • I have been playing around with Metro-style apps in C# and also Javascript. And when I go to Publish my JavaScript app, it succeeds (apparently), but it does not show up on the Start screen, but it does appear in the Apps section of the Start screen (apps screen shows all apps), but upon clicking my app's tile, i am confronted with the Windows Store App! Not my own app. Even though I chose to publish the app locally, and not to the store.

     

    Anybody else encountering this, or other publishing issues and do you know of any workarounds?


    • Edited by J. Kent Saturday, December 3, 2011 12:42 PM
    Saturday, December 3, 2011 11:53 AM

All replies

  • Hi J,

    Can you try a simple Javascript Metro Style app (Just a Hello World app) and see if you have the same issue?

    -Jeff


    Jeff Sanders (MSFT)
    Monday, December 5, 2011 12:37 PM
    Moderator
  • Thanks for getting back Jeff,

     

    I have been trying other Samples (including a Hellow World app that displays a TextBlock with text, and not just Javascript, C# as well) since, and am experiencing the same issue. First, when I right-click and select Run As Admin on the .bat file, the console opens and fails (something about an unpackaged version already being installed) so when I change the name in App Manifest settings in VS, and re-run that .bat file it packages successfully (sometimes).

     

    But still won't open. It still opens the Windows Store app.

    Monday, December 5, 2011 1:53 PM
  • Hi J,

    For the first part, make sure you uninstall the previous version first (Windows Key, type in the name of your app and when you find it right click or select gesture and choose uninstall).

    The second issue... Very strange. 

    After uninstalling your test app, follow the instructions on this page noting this especially:Build a package to use locally only

    http://msdn.microsoft.com/en-us/library/windows/apps/br230835.aspx

    Build your app's packages using Visual Studio

    1. In the Solution Explorer of Visual Studio 11 Express for Windows Developer Preview, select the app in your project.
    2. From the Store menu item, select Create App Package...
    3. In the Build Package dialog box, select Build a package to use locally only, and then click Next.
    4. Select the folder for the resulting package and set the version number that you want to assign to the package.
    5. Review the summary information, and then click Build to build the package.
    6. Review the results and the path to the package file in the Output window.

    -Jeff

     


    Jeff Sanders (MSFT)
    • Marked as answer by J. Kent Monday, December 5, 2011 4:01 PM
    • Unmarked as answer by J. Kent Monday, December 5, 2011 4:01 PM
    Monday, December 5, 2011 2:07 PM
    Moderator
  • Hi Jeff,

     

    Thanks for the heads up on uninstalling first.

     

    Regarding the app not opening, I'm still experiencing the same problem. I did go to that link and have followed those steps. Those were the steps I was originally using in the first place.


    As you can see, from the images below I've followed the instructions correctly. It's very strange that I'm having this problem:

     


    • Edited by J. Kent Monday, December 5, 2011 6:58 PM Added detail
    Monday, December 5, 2011 4:03 PM
  • That is really bizarre...  The only reason I could think of it going to the store is if you had not selected: Build a package to use locally only but by selecting the local and Store option!  I don't think there is a code path to the store unless you choose the first option.

    Triple check that option.


    Jeff Sanders (MSFT)
    Monday, December 5, 2011 4:08 PM
    Moderator