none
Issue with <Any> type while using WCF-SQL Adapter RRS feed

  • Question

  • Hello,

    To test using wcf-sql adapter, I just tried implement a sample scenario to retrieve data from a table using stored procedure(which contains simple select statement) in Biztalk as soon as a request for that data is received. When  i used that adapetr i got two .xsd files saying proceduredbo.xsd and dataset.xsd and a binding file. A dataset is returned as a response which contains two <Any> elements. I am confused about what is this and whether is this the case with whoever worked wid dis adapter?

     

    Well, somehow with my own assumptions and little knowledge i published it as service and consumed it in .net. I got the output with some part of coding involved on the client side(.net) like converting it into xml string blah blah blah....

     

    But when I try to import this service in infopath, it does not get the data fields. It is not able to understand that dataset..Can anyone throw light on these issues?

     

    Thanks,

     

    Anusha.

    Monday, February 7, 2011 7:45 PM

Answers

  • I think that schema with the <Any> fields is generated when you choose untyped objects in the generate schemas wizard. You need to choose typed objects to have it generate the meaningful, contextual schemas.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Tuesday, February 8, 2011 6:50 AM
    Moderator