locked
Login failed for user RRS feed

  • Question

  • Hi

    I am trying to log into SQL management studio SQL 2008 R2 on server 2008 R2. I am getting the below error when trying to log in. I have permission to log in and i have a remote session onto the server using rdp.

    Login failed for user 'EU01\admin_smw'. Reason: Token-based server access validation failed with an infrastructure error. Check for previous errors. [CLIENT: <local machine>]

    Any ideas why?

    Thanks

    Shane

    Monday, September 12, 2016 8:02 AM

Answers

All replies

  • Hi Shane Walford,

    Since you have RDP access to the server, I would suggest you check SQL Server log or Event Viewer\Windows Logs\Application log on the server for more detailed error message. After that, you could compare the error state to this list see if it helps.

    If you have any other questions, please let me know.

    Regards,
    Lin
    Monday, September 12, 2016 8:13 AM
  • Might be a UAC issue. Is it working if you run SSMS as Administrator?
    Monday, September 12, 2016 8:14 AM
  • No, run as admin and i still get the same error.

    This is the error information from the error in SSMS. 

    Error Number: 18456
    Severity: 14
    State: 1
    Line Number: 65536
    Monday, September 12, 2016 8:35 AM
  • Hi Shane Walford,

    The error state for error 18456 will always be 1 in SSMS for security reasons. Since you have RDP access to the server, I would suggest you locate and check SQL Server log by following this guide or check on Event Viewer\Windows Logs\Application log on the server for more detailed error message.
    If you have any other questions, please let me know.

    Regards,
    Lin
    Monday, September 12, 2016 8:42 AM
  • Hello Shane

    This may indicate that the user has another session open but the Password has been changed.


    Please click "Mark As Answer" if my post helped. Tony C.

    Monday, September 12, 2016 9:05 AM
  • can you please check do you have accesses for the SQL server &  is that sql server service account is in domain, if so please check appropriate SPN is set .

    Also did your account is added to the sql (or) you are part of the group & added this group to the SQL along with proper permission required(required grant permission for connect).

    this seems to like an -some domain level issues for your account, please check more in the sql errorlog/eventlog as said Lin.

    see if anyone is able to connect then verify the settings with them ,check with your colleague as well.

    even if you are trying to connect using different domain,then trust need to be apply b/w current issue server to the server which you are trying.

    verify your firewall is not blocking too.

    verify shared memory also is enabled-fyii


    Regards, S_NO "_"



    • Edited by S_NO Monday, September 12, 2016 10:08 AM add
    Monday, September 12, 2016 9:18 AM
  • Thanks for all the replies.

    I just noticed that the SQL server browser service was disabled. I enabled this and i can now log in, but i have an issues accessing the database where i get the below error:

    The database (database name) is not accessible. (object explorer)

    Any ideas?

    Monday, September 12, 2016 10:46 AM
  • Funny that starting the browser service would resolve the error. If the browser service is not running, you would typically get an error that SQL Server is not reachable at all - if you need the browser at all, that is.

    The message Token-based server access validation failed with an infrastructure error usually indicates one of two things:

    1) (In case of Windows authentication), a mismatch between SQL Server and the AD with your account, typically because of a change in the AD. Resolution: drop the login in SQL Server and recreate it.

    2) Lack of CONNECT SQL permissions or lack of CONNECT permissions on the endpoint you are trying to use.

    The error about the database not be accessible is less obscure. Why the database is not accessible I cannot tell, since I don't have access to the server. But it could be set to single_user, be in the middle of a restore etc. Or you may not be registered as a user in the same.

    Monday, September 12, 2016 11:02 AM
  • Thanks for all the replies.

    I just noticed that the SQL server browser service was disabled. I enabled this and i can now log in, but i have an issues accessing the database where i get the below error:

    The database (database name) is not accessible. (object explorer)

    Any ideas?

    The database (database name) is not accessible. (object explorer)

    >> this might be you are trying on the wrong database something like restoring,dbmirror kind (or) lack of permissions.

    or 

    issues with your database as well like offline (or) calling the wrong database name.

    >>check what is the status of your database first,if really issues with database then you have to scan the errorlogs to see any errors.

    exactly cannot be tell but it is worth to re verify.


    Regards, S_NO "_"

    Monday, September 12, 2016 11:12 AM
  • You must start the sqlserver instance with parameters -m, after start SQL Server Management Studio with windows authentication.

    Now you are a sysadmin, assign the sysadmin role to your user, exit and remove the -m parameter and restart sql server

    Sorry, I think you misread the original post. This suggestion is for a totally unrelated problem. Nobody said the login has to be member of sysadmin.

    Tuesday, September 13, 2016 7:45 AM
  • This is now working. After a server reboot i could get into SSMS so not really sure why.

    Thanks for all input.

    Shane

    Wednesday, September 14, 2016 2:38 PM