The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Azure Multi-Factor Authentication!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
Being asked for MFA twice RRS feed

  • Question

  • I have a basic Azure tenant with a small pay-as-you-go subscription that is for my DNS record hosting, I have no other paid services except that and eveything is linked to my personal Outlook.com email address. The Outlook.com account is protected by passwordless MFA with the Microsoft authenticator app and it all works very well outside of Azure.

    However, when I connect to the Azure portal with the same Outlook.com account I am prompted to approve the login with the app, which works as expected, but then immediately afterwards I get a second MFA prompt that is sending and SMS text code which I have to enter. Where is this coming from and how do I disable it? When I check in the Multifactor Authentication from the Users blade, it says disabled and any options are greyed out for the account.

    Thursday, October 24, 2019 6:23 AM

All replies

  • So here's what would have happened with your Outlook.com email.

    When you created the Live Account, there would have been the second challenge configured for your Outlook.com email, which is what prompting you for the first MFA challenge from the Authenticator App.

    Now, as the Admin in the Azure Tenant, you would be getting a "Conditional Access Policy" challenge which is sending you the code to enter.

    Here's how you can check for the tenant Conditional Access Policy.

    Login to the Azure Portal using the same credentials. On the left pane, select All Services. Then search for Conditional Access Policy. On the Conditional Access - Policies blade, you might find a "Baseline Policy: Require MFA for Admins".

    Select the same and you would come to the place you Enable or Disable the same. Select "Do not use policy" and then Save. Now, I would suggest you to logout and try to re-login from a different browser and check again.

    Hope this helps.

    -----------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Thursday, October 24, 2019 8:49 AM
    Moderator
  • Sorry, but I don't have access to any Conditional Access options with my tenant:


    Monday, October 28, 2019 6:50 AM