locked
Server Error in '/' Application RRS feed

  • Question

  • User-1783546246 posted

    Hi - on my first asp.net 4.5 web site

    I have a conventional html web site hosted by Fasthosts recently updated to Windows Server 2008 with asp.net 4.5.  Within the folder system I have created an asp.net  web site, which I have published using ftp within VS2012.  default.aspc is a straight forward page to determine if the browser language is English or German and redirect the user to ewelcome.aspx of dwelcome.aspx - both of these use a specific master page.  The default page works fine but when I try to move to the ewelcome.aspx page (or any other page by name) I get the error:

    Server Error in '/' Application  The resource cannot be found. Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.  Requested URL: /ewelcome.aspx

    I have not touched the web.config file:

    <?xml version="1.0"?>
    <configuration>
        <system.web>
          <compilation debug="true" strict="false" explicit="true" targetFramework="4.5" />
          <httpRuntime targetFramework="4.5" />
        </system.web>
    </configuration>

    I am publishing to the HTDOCS folder

    Any help / advice appreciated

    Friday, May 24, 2013 6:50 PM

Answers

  • User-1783546246 posted

    Problem solved - although not exactly sure on why as 2 things happened

    I had uploaded the original site using expression web - uploaded the asp.net site from within vs and the 'two' roots became confused!  Uploaded the asp from host file manager and things started to improve.  A page with no master page worked fine - but not one with a master.  Found a slight error on that page and it then worked.  Other pages didn't work but all i did was to open them in vs - check they did not have the error - they didn't - saved them and uploaded and they then worked - strange

    Thank you ....

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, May 26, 2013 3:40 AM

All replies

  • User-1469158370 posted

    If you look at the error it says that the ewelcome.aspx page is not available at the root folder.

    Is ewelcome.aspx page located in the root folder?

    Saturday, May 25, 2013 10:25 AM
  • User-1783546246 posted

    Thanks for your interest - The original site (with FP extensions) exists at eg domain.co.uk with several sub folders - all conventional html.  I created a new asp.net web site in a new sub folder within this web and put all of the files into it including the ewelcome.aspx page and default.aspx.

    If I use ftp from VS2012 to look at domain.co.uk/subfolder I can see all the files - if I navigate to the folder I get the default.aspx page OK from here if I click on the link to the english welcome page ewelcome.aspx I get the error.  If I navigate to any other page I get the error.  All of the pages other than default.aspx use a master page.

    I have tried publsihing to htdocs and to htdocs/subfolder - all same error

    Saturday, May 25, 2013 3:56 PM
  • User-1783546246 posted

    Problem solved - although not exactly sure on why as 2 things happened

    I had uploaded the original site using expression web - uploaded the asp.net site from within vs and the 'two' roots became confused!  Uploaded the asp from host file manager and things started to improve.  A page with no master page worked fine - but not one with a master.  Found a slight error on that page and it then worked.  Other pages didn't work but all i did was to open them in vs - check they did not have the error - they didn't - saved them and uploaded and they then worked - strange

    Thank you ....

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, May 26, 2013 3:40 AM