locked
Disable spellcheck - Internet Explorer's performance is slow after a word has been misspelled

    Question

  • Whenever I'm on facebook, when I try to type something it works fine untill it encounters a spelling mistake. As soon as it detects one, I can hardly type on facebook, even if I correct it, I still type at 1 character per second, is there a fix to this? And if not, how can I disable the spell checker?

    Regards,

    Dylan Meeus


    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Wednesday, September 14, 2011 7:27 PM

Answers

  • To everyone still here, I actually found something that makes it work.
    I just kill off the spellchecking process so it doesn't correct facebook anymore. This way I'm  rid of the spellchecker for sure.

    Regards,

    Dylan Meeus


    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    • Marked as answer by Dylan-Meeus Sunday, September 18, 2011 3:56 AM
    Sunday, September 18, 2011 3:56 AM

All replies

  • I have the same issue too ..
    Juan Alvarado - MVP SQL SERVER
    Thursday, September 15, 2011 1:10 AM
  • Can you clarify: Are you typing using a hardware keyboard or using the on-screen touch keyboard?

    Thursday, September 15, 2011 5:15 AM
  • USB 2.0 keyboard.
    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Thursday, September 15, 2011 5:16 AM
  • my problem is in a normal laptop.  The facebook is very slow down when i type some characters.  I think the problem is the spelling check but we don't know how to disable.
    Juan Alvarado - MVP SQL SERVER
    Thursday, September 15, 2011 2:26 PM
  • Hey everyone,

     

    Does this problem happen in both the Metro pinned Internet Explorer that is on the Start screen and the desktop version that can be switched to by following the steps below:

    • Open Internet Explorer from the Start screen
    • Right click to show the Address bar
    • Click the page icon that is displayed to the right of the Address bar (directly left of the forward button/icon)
    • Click Use desktop view

     

    Then the desktop version of Internet Explorer will load. Also, is the problem specific to Facebook.com? Try visiting another website and test to see if the same problem happens.

     

    Look forward to hearing back from you.


    Steven
    Sunday, September 18, 2011 2:42 AM
    Moderator
  • It's not in the Metro UI browser, it's just on the desktop one.
    To me it doesn't only happen on facebook, it happens on any site (such as this one if a word gets underlined).

    Regards,

    Dylan Meeus


    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Sunday, September 18, 2011 2:44 AM
  • Hey Dylan,

     

    Try resetting the desktop Internet Explorer's settings by following these steps:

    • Open the desktop Internet Explorer
    • Click Tools
    • Click Internet Options
    • Click the Advanced tab
    • Click Reset...
    • Click Reset
    • Click Close
    • Close all Internet Explorer windows
    • Open Internet Explorer

     

    Then test to see if the same problem occurs.


    Steven
    Sunday, September 18, 2011 2:50 AM
    Moderator
  • Thanks Steven, I just went and tried it out.
    No success there Steve.
    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Sunday, September 18, 2011 2:54 AM
  • Also as an update: on the metro IE version, it doesn't lag at all, up untill you've misspelled like 20 words or more! and even then the lag there was barely noticable.
    Performance issue in IE10?

     


    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Sunday, September 18, 2011 3:26 AM
  • To everyone still here, I actually found something that makes it work.
    I just kill off the spellchecking process so it doesn't correct facebook anymore. This way I'm  rid of the spellchecker for sure.

    Regards,

    Dylan Meeus


    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    • Marked as answer by Dylan-Meeus Sunday, September 18, 2011 3:56 AM
    Sunday, September 18, 2011 3:56 AM
  • Whenever I'm on facebook, when I try to type something it works fine untill it encounters a spelling mistake. As soon as it detects one, I can hardly type on facebook, even if I correct it, I still type at 1 character per second, is there a fix to this? And if not, how can I disable the spell checker?


    I don't seem to notice that problem when making spelling mistakes replying to answers in this forum.   Believe me, I make lot of spelling mistakes.  I am *VERY* happy that Microsoft has finally decided to put spell check into IE out of the box.  Even though I am a professional web developer and should be more concerned about things like CSS Selectors, DOM Storage [1], JavaScript constants [2] and JavaScript type checking [3], you would be surprised how much having IE Spell Check out of the box has improved my happiness factor.

    [1] - http://msdn.microsoft.com/en-us/library/cc197062(v=VS.85).aspx

    [2] - IE JavaScript still doesn't seem to support the "const" keyword.  This simple program won't run on IE10:

    <script>
    const var text = 'hello';
    alert(text);
    </script>

    but this will

    <script>
    var text = 'hello';
    alert(text);
    </script>

    I'm pretty sure "const" is supported in FireFox and Chrome:

    http://comparexy.com/compare/const+vs+var+in+JavaScript

    [3] - JavaScript static type checking appears to be a candidate for ECMAScript4 http://en.wikipedia.org/wiki/ECMAScript but for some reason, the creation of the standard appears to be stalled...


    • Edited by Shawn Eary Sunday, September 18, 2011 4:04 AM
    Sunday, September 18, 2011 4:03 AM
  • Mi spel chcek doesnt work as yu can see. How can i turn it on again??
    Wednesday, September 21, 2011 6:05 PM
  • Under the control panel & then General -> Spelling.

    Regards,

    Dylan Meeus


    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Wednesday, September 21, 2011 6:06 PM
  • Well i don't see it, but suddenly  it started working again, funny thing...
    Wednesday, September 21, 2011 6:17 PM
  • Lol well all good then :)
    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Wednesday, September 21, 2011 6:39 PM