Why I can't authorize guest users? RRS feed

  • Question

  • i want assgin licenses to guest user.prompt:

    AAD Error Details

    Licenses not assigned

    License cannot be assigned to a user without a usage location specified.

    I not found set location position

    I need help~

    • Edited by 792670743 Thursday, December 13, 2018 11:37 AM
    Thursday, December 13, 2018 11:36 AM

All replies

  • Hi,

    you can use portal.azure.com and edit a user, there you can set the "Location".

    If you need to sync this option from onPrem set the msExchUsageLocation attribute, values are 2-digit language code like US or DE or GB


    Peter Stapf - ExpertCircle GmbH - My blog: JustIDM.wordpress.com

    Thursday, December 13, 2018 12:37 PM
  • You can follow the steps mentioned here to update the location of the user through Azure Portal.

    You can also follow the steps mentioned here to update this through Powershell.

    Example of setting usage location to France

    $userName="Belinda Newman"
    $upn=(Get-AzureADUser | where {$_.DisplayName -eq $userName}).UserPrincipalName
    Set-AzureADUser -ObjectID $upn -UsageLocation "FR"

    Tuesday, December 18, 2018 5:08 AM
  • Please let us know if you find above reply useful. If yes, do click on 'Mark as answer' link in above reply. This will help other community members facing similar query to refer to this solution. Thanks.
    Thursday, December 27, 2018 12:57 AM
  • Hi,

    1. Open the user profile e.g. Home>Default>User - All Users> Test User 1 -Profile

    2. In the "Settings" pane of User profile select your Country Name from "Usage Location" Drop down menu. 

    Hope this will resolve you issue.

    Thanks and Best Regards

    • Proposed as answer by Minhuj Monday, April 22, 2019 4:22 PM
    Wednesday, April 10, 2019 8:17 PM