none
Boot Windows Embedded Compact 7 from USB RRS feed

  • Question

  • I've read over the forums and seen many posts about booting USB from flash and haven't had much success.  I'm hoping someone can help point me in the right direction or let me know if it is even possible.

    Question / Case:

    I'm attempting to create a Windows Embedded Compact 7 image and have that image boot from USB stick.  I'd like to be able to take the USB Stick to my target device, plug in the USB stick, start the device, device boot into Windows Embedded Compact 7 Image and then be able to interact with the OS.  The image will be very basica, based on x86, and really only offer up RDP, to allow user to connect to a RDS server.

    Is this functionality possible?  I believe it is...

    So far:

    I currently have success in creating OS Image and booting to them in Virtual PC.  I'd like to take one of these images and place it onto the USB and boot to it.

    I've followed these basic instructions (create vCEPC) creating a vCEPC, then start my VM, in VStudio attach the device and see that the VM connects and downloads the image. I've followed the same steps for CEPC and BSP generic template and can connect and download when using Virtual PC.  

    What I'd like to do now:

    I'd like to move the OS image, mentioned above, to a USB stick and boot to it.  When doing this I only get the Windows Embedded CE splash screen and then goes blank and nothing happens.

    Can any help or assist me in working through the issue?

    I've attempted all or part of solutions located in these posts.

    Embedded - Configure Flash Storage to Launch Compact 7 using DiskPrep

    Used to help create bootable USB

    Seems to indicate its doable

    Use DOS to boot WinCE.. Wasn't 100% clear on all the instructions..

    I'm hoping someone can assist me in what I'm trying to do.  I welcome any questions you may have to get more clarity or ask if i've done something /try something. etc..

    Thank you!

    Tuesday, September 18, 2012 8:52 PM

All replies

  • It is possible.  It looks like you are doing it since you get the splash screen.

    Now, you need to tell us what you have on your boot disk.   Some debug output would also be helpful.


    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman

    Eurotech Inc.
    www.Eurotech.com

    Wednesday, September 19, 2012 12:16 PM
    Moderator
  • On the USB Stick (hidden files / folder showing):

    BLDR

    Boot.ini

    NK.bin

    SPLASH.BMX

    clientshutdown.exe

    CMAccept.exe

    ConmanClient2.exe

    eDbgTL.dll

    TcpConnectionA.dll

    I should be able to provide any debug info..  I'm new to Windows Embedded Compact, so if you could maybe point me to the log files or debug info that would be helpful.

    Yesterday evening I tried the following, same result.  Splash Screen and nothing after that, just blank screen.   These steps produced what you see on the USB stick listed above.

    I followed the steps here Create VHD stand alone and Stand alone use.  I tested the OS Image in Virtual PC and it worked.  I used the same steps but instead of creating a VHD, i pointed the disk prep utility to the USB Stick and followed the same steps..

    Thoughts?  

    Wednesday, September 19, 2012 3:53 PM
  • Additional info about the image I created and the system I'm trying to insert the USB into to boot with..

    BSP: Virtual PC: x86  (Used pretty much the standard settings described in the MSDN links in previous post)

    Samsung Notebook:  

    Series 7 

    Intel Core i7 processor  (64bit)


    • Edited by fugaz13 Wednesday, September 19, 2012 5:43 PM
    Wednesday, September 19, 2012 4:11 PM
  • I’ve been working to get this to work throughout the day.. In the process I’ve changed the approach after reading the following post regarding the various bootloaders with WEC7..  WEC7 Boot Loaders  

    I’ve decided to start from scratch and worked from the BSP “Generic CEPC: x85”.  I’ve walked through the creation use the default settings and followed steps located in the PDF “Advanced Virtual CEPC” guide.  Yes I know it indicates Virtual but I’m leveraging the discussion regarding VHD and replacing with USB Stick.


    1.  OS Image Built successfully, In VStudio after the build it indicates no errors in the output field.  I selected Platform Builder Debug and saw no errors.   This created a NK.bin file located in <D:\Development\WINCE700\OSDesigns\Project1\TestOS\TestOS\RelDir\CEPC_x86_Release\nk.bin>.  I made sure KITL was disabled.  

    2.  From here I prepared the USB Stick by running diskpart, cleared the USB stick, formatted, created a partition on it and made it active.

    3. Then I created the boot loader by using the CeSYS command located in D:\Development\WINCE700\platform\CEPC\src\boot\tools\bin\i386 and the wceldrc file located in D:\Development\WINCE700\OSDesigns\Project1\TestOS\TestOS\RelDir\CEPC_x86_Release

    Ran the following command from CMD  “cesys g: wceldrC -f”   

    This ran and indicated “Boot Loader transfered on drive g:

    4.  Now I added the OS Image to the USB stick by doing the following from a CMD window, change to the path above for the CEPC_x85_Release folder to copy the NK.bin file to G:

    copy NK.bin g:

    5. Then I copied communication files over from C:\Program Files (x86)\Common Files\microsoft shared\CoreCon\1.0\Target\wce400\x86

    copy Clientshutdown.exe G:
    copy ConmanClient2.exe G:
    copy CMaccept.exe G:
    copy eDbgTL.dll G:
    copy TcpConnectionA.dll G:

    6.  After this disconnect the USB and attempt to boot the target Samsung Notebook.
    I know get the WCELDR loader, which gives me the following options:
    [1] Show Current Settings
    [2] Set Boot Device
    [3] Select KITL Device
    [4] Network Settings
    [5] Display Settings
    [6] Debug Port Settings
    [7] Save Settings
    [0] Exit and Continue

    7.  Upon boot I hit space bar.
    8.  Select 2 for boot device
    9.  In the select boot source submenu I select 1
    10.  Select 1 again to show current settings
    11. then hit 7 to save

    From here it continues to boot, i see activity on the stick and about 3-4 minutes later screen goes blank.


    Thoughts?









    • Edited by fugaz13 Thursday, September 20, 2012 9:22 PM
    Thursday, September 20, 2012 3:32 AM
  • Update:

    Using the above steps I took the USB I create and moved to a new target machine instead of the Samsung Notebook and this time it boots all they way to the desktop.   I can move around the OS etc, but I have no network connectivity.

    The system that booted to the WEC7 desktop, is a dell system with Broadcom NetXtreme Gigabit Ethernet  (driver file: b57nd60x.sys)

    In the OS Design I've selected the following options, but can't seem to determine why I can't get network connectivity...

    BSP = Generic CEPC: x86

    Core OS: (under there for network is what is checked and I'll list the path to the setting)

    Core OS > Windows Embedded Compact > Communication Services and Networking > Networking - local area network > Wired LAN(802.3, 802.5) & Wireless LAN 802.11 STA  are both checked.

    Core OS > Windows Embedded Compact > Device Drivers > Networking > LAN devices > NE2000 for PCI/ISA and RealTek RTL8139 are both checked.

    Core OS > Windows Embedded Compact > Device Drivers > Networking > WAN devices > Asyncmac NDIS driver  is checked

    Is there something I'm missing for network adapters to enable network connectivity?  Will I need to add drivers for Broadcom to make it work?  If so, does anyone know of a resource to review so I can determine how to add those drivers to the OS?

    Thanks!

    Thursday, September 20, 2012 9:22 PM
  • Hoping someone can read over these posts and provide some input / suggestions??

    So far it looks like I'm getting my OS Image to boot to the desktop.  Issue I'm having now, as noted in previous reply by me, is I have no network connectivity.

    The desktop I'm testing on has the Broadcom NetXtreme ethernet...     

    I've browsed and Google'd looking for resource / information for developing the driver for the card but I'm not having much luck.  This may be over my head but hey you have to start somewhere.  I found this link at Broadcom "Ethernet NIC Open Source Developer Resources" which I believe is the location I need to pull the source / manuals for enabling this network adapter on my system.  

    Can anyone help by providing any additional resources on how to add the drivers needed for the Broadcom NetXtreme ethernet??

    Any help is appreciated.

    Friday, September 21, 2012 12:11 AM
  • Did anybody found an answer for this?
    Monday, April 1, 2013 12:23 PM
  • Hi Sujit,

    You can follow following link for booting Windows CE with USB:

    http://geekswithblogs.net/deepak_/archive/2013/04/03/booting-windows-ce-using-usb.aspx

    Hope this helps..


    Please remember to mark the replies as helpful if they help and mark as Answers if they answer your query.


    • Edited by deepak_ Wednesday, April 10, 2013 9:38 AM
    Wednesday, April 3, 2013 2:49 PM