locked
FirstLogonCommand after Sysprep RRS feed

  • Question

  • HI,

    I looking for automaticaly rename 2 * network names after clonning.

    To do that :

    • I write a WMI script using netsh interface set name=xxx newname=yyy, working well in normal use
    • In sysprep unattend file add FirstLogonCommand launching WMI Script
    • In sysprep unattend file add autologon on admin user
    • lunch: Sysprep /generalize /oobe /reboot /unattend:sysprep.xml

    Result is fisrt card is not rename, second card is rename with first rename

    have you a idea ? or solution ?

    Thanks

    Friday, October 4, 2013 3:26 PM

Answers

  • Thanks Knarz,

    This method give all satisfaction.

    Regards,

    • Marked as answer by NSebille Monday, October 7, 2013 8:33 AM
    Monday, October 7, 2013 8:32 AM

All replies

  • Sounds like this need to be completed when you are fully logged into the account. Try setup complete:

    http://technet.microsoft.com/en-us/library/cc766314(v=ws.10).aspx


    www.annabooks.com / www.seanliming.com / Book Author - Pro Guide to WE8S, Pro Guide to WES 7, Pro Guide to POS for .NET

    Friday, October 4, 2013 3:42 PM
  • I had some Problems with netsh interface therefore i'm using wmic:
    wmic nic where "NetConnectionId = 'Local Area Connection'" set NetConnectionId = "Something Other"


    Windows Embedded Developer and Scripting Guy //Germany (http://www.wesnext.com)

    Monday, October 7, 2013 1:48 AM
  • Hi Sean,

    It's seems that Setupcomplete.cmd don't work after sysprep. I did some tests with only write log and nothing append.

    Regards,

    Monday, October 7, 2013 8:30 AM
  • Thanks Knarz,

    This method give all satisfaction.

    Regards,

    • Marked as answer by NSebille Monday, October 7, 2013 8:33 AM
    Monday, October 7, 2013 8:32 AM