none
Error when installing Net framework 3.5 RRS feed

  • Question

  • Hello there,

    Today I tried installing Visual Studio 2008 Express Edition which sadly required 3.5 net framework to work, and got an error saying that an error has occured while installing the net framework. I tried searching the internet for solutions to the problem and noticed that there were many similar problems but I couldn't find any that matched mine so here am I asking for help.

    I tried completely uninstalling the net framework I had (2.0) using the Cleanup tool mentioned in another forum post. After that I tried installing the net frame again and I still got the error. 

    In another forum post I read about this Log Tool that checked my problem. I ran it and here is what I got:
    dd_dotnetfx35error.txt: [10/03/10,17:47:52] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation."
                                       [10/03/10,17:47:53] WIC Installer: [2] Setup Failed on component WIC Installer
                                       [10/03/10,17:48:04] WapUI: [2] DepCheck indicates WIC Installer is not installed.

    dd_WIC.txt: [dd_WIC.txt]
    0.047: ================================================================================
    0.047: 2010/10/03 17:47:52.265 (local)
    0.047: d:\52bd6479521b09e256122c\update\update.exe (version 6.3.4.0)
    0.062: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Strahil\LOCALS~1\Temp\dd_WIC.txt
    0.062: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.062:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.062: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.062: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.062:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.062: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.062: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.062:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.062: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.062: Condition Check for Line 3 of PreRequisite returned FALSE
    0.078: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.109: Newer version of update is already on the system.
    0.109: Update.exe extended error code = 0xf0f4
    0.109: Update.exe return code was masked to 0x643 for MSI custom action compliance.

    I googled these lines and went to a forum post saying that my WIC version needed upgrade and so I went to the Microsoft website to upgrade it, when I tried doing so I got a msg telling me that my version was newer. Then I tried following these instructions: http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/8cce5c65-8c3f-4d13-8800-72e4238d4a04 and still nothing when I tried.

    Im running Windows XP SP3 and Ill be glad if you could help me.

    Also Im sorry if I did something wrong.

    Sunday, October 3, 2010 3:20 PM

Answers

All replies