locked
BING Coginitive API missing few results from the live site RRS feed

  • Question

  • Hello:

    I am trying to compare the results from API vs the live site, looks like its missing lots of results.

    I am using the API tester tool:

    https://www.microsoft.com/cognitive-services/en-us/bing-web-search-api

    My search term is: criminal+case+site:https://play.google.com/store/apps

    responseFilter:webpages

    websearchurl  from JSON response:

    "webSearchUrl":"https://www.bing.com/cr?IG=116F92F14893479BBE658EFC78256E22&CID=2F85CF21E8B169D5111CC6F3E98068B5&rd=1&h=2QEIk_DaYy7jbQ7RmNN6JkXWs4TbP9q88_HdiZhZkyQ&v=1&r=https%3a%2f%2fwww.bing.com%2fsearch%3fq%3dcriminal%252bcase%252bsite%253ahttps%253a%252f%252fplay.google.com%252fstore%252fapps&p=DevEx,5249.1"

    When i compare the results its missing atleast the first 5 results.

    Also, When i compare the same search with existing Azure API, the results are totally different.

    All the results we get from azure are the results from google play app store, But in Cognitive its not the case.

    Any Idea how we can fix this?

    Appreciate your help

    -Skoppal




    <object data-extension-version="0.4.0.129" data-install-updates-user-configuration="true" id="__symantecPKIClientMessenger" style="display:none;"></object>
    • Edited by SKoppal Monday, November 21, 2016 2:26 AM
    Saturday, November 19, 2016 12:15 AM

All replies

  • changing the advance search operator in search term from site to domain, got more and relevant results.

    Is this something which changed in the new Cognitive API?

    <object data-extension-version="0.4.0.129" data-install-updates-user-configuration="true" id="__symantecPKIClientMessenger" style="display:none;"></object>
    <object data-extension-version="0.4.0.129" data-install-updates-user-configuration="true" id="__symantecPKIClientMessenger" style="display:none;"></object>
    • Edited by SKoppal Monday, November 21, 2016 9:29 PM
    Monday, November 21, 2016 7:53 PM