none
Unable to run unit tests RRS feed

  • Question

  • Hi, I am new to unit testings, I am using the default VS unit test framework. I have two unit tests I want to run:

     [TestClass()]
        public class EmployeeTreeTests
        {
            [TestMethod()]
            public void RemoveEmployeeEnteryPointTest()
            {
               //content...
                bool Test = //condition
                Assert.IsFalse(Test);
            }
            [TestMethod()]
            public void RemainAtMemory()
            {
               //content...
                bool Test = //condition
                Assert.IsTrue(Test);
            }
        }

    The problem is not with the unit test themself, It just that one of them (RemoveEmployeeEnteryPointTest) won't even run, even when I click "run all" and even if I click specifically on this unit test and then click run, it just won't run, not displaying X or V icon, instead displaying the "!" icom (means that the unit test did not run yet) I don't know what have I done wrong, can it do with the fact I have extensions installed ( or some VS bug ?) I use the last version of VS community. How can I run both of my unit test properly?a

     
    • Edited by avivgood Tuesday, October 22, 2019 7:20 PM
    Tuesday, October 22, 2019 7:14 PM

Answers

  • It's where you can post for help.

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=vsunittest

    • Marked as answer by avivgood Tuesday, October 22, 2019 7:57 PM
    Tuesday, October 22, 2019 7:39 PM

All replies

  • It's where you can post for help.

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=vsunittest

    • Marked as answer by avivgood Tuesday, October 22, 2019 7:57 PM
    Tuesday, October 22, 2019 7:39 PM
  • Is it possible to migrate the question to a different forum without deleting and rewriting it in the correct forum? because if I do so I will probably get marked as spam as the bot is recognizing those two questions asked one after the other as similar and thinks it is spam, It happened to me quite a lot when I have tried to migrate a question to a different fourme that's why I ask.

    • Edited by avivgood Tuesday, October 22, 2019 7:47 PM
    Tuesday, October 22, 2019 7:45 PM
  • The moderator will move the thread if he or she sees your post concerning the thread be moved.
    Tuesday, October 22, 2019 8:51 PM