locked
Cannot connect to Windows Azure when pubblishing LighSwitch 2012 Application RRS feed

  • Question

  • Hi,

    Months ago I've developed a published a LightSwitch  application developed with VS 2012.

    Now I'm trying to publish some updates, but when I reach the "Service Configuration"page in the Publish Wizard the drop down list of available web sites is empty but a "Cannot connect to Windows Azure" element.

    So I've installed VS 2012 to the last update, then I've deleted all previous uploaded certificates in my subscription and recreated a uploaded a new one, but nothing has changed.

    A few days ago, however, I've installed VS 2013 on the same machine.

    Please help,

    Thanks a lot,

    Gennaro.

    Friday, February 14, 2014 1:47 PM

Answers

  • Unfortunately, the API to retrieve Azure Web Sites has been updated and is now incompatible with the LightSwitch Publish Wizard in v2 projects (VS 2012 Silverlight Projects that have not been upgraded by right-clicking on the project and selecting Upgrade).

    This means it is not possible to publish to an Azure Web Site via the Azure path of the wizard.  It is possible though to publish to an Azure Web Site via the IIS path.  Follow the steps in this blog post and you should be able to publish:

    Publish LightSwitch 2013 Preview Applications to Windows Azure Web Sites (without the Azure SDK)


    David Kidder | Senior SDET | Microsoft | LightSwitch

    Wednesday, March 5, 2014 8:08 PM
    Moderator

All replies

  • LightSwitch uses customized dialogs for this. Your question would be better for the LightSwitch forum. I'll go ahead and move it for you.

    The LightSwitch forum is located here.


    Jim Cheshire | Microsoft


    Friday, February 14, 2014 2:55 PM
  • Not sure if it's the same issue, but in VS2013 I find that publishing to Azure fails unless I first go into Server Explorer and expand the Windows Azure node and then expand the Web Servers node. It's only at that time that VS actually logs into Azure, even though it already has the account info.

    Paul

    Friday, February 14, 2014 4:41 PM
  • Hi,

    I'm still stuck on the publishing issue.

    The only symptom is that the Service Configuration drop box doesn't show the Windows Azure list of available web site.

    Any Idea?

    Thanks.

    Tuesday, February 18, 2014 10:34 AM
  • HI Gennaro

    We can specify the Website we want to publish to using the Service Configuration. This will be the same website you specified in the portal.

    Please follow the steps below to deploy your LightSwitch app to Windows Azure,

    Deploy Your LightSwitch Apps to Azure Websites

    If it still has same problem, please let me know.

    Best regards

    Angie Xu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, February 24, 2014 5:19 AM
  • Hi Angie,

    Tanks a lot for your reply.

    As I wrote in my first post, I've already published (about one year ago) my application to Windows Azure. This time I am just trying to publish some updates, but after updating VS2012 to last update (and installing VS2013 on the same machine) I'm not able to publish any more.

     I can connect to Windows Azure node on the Server Explorer and get the available web sites list, but in the Publishing Wizard on the Service Configuration page the drop down box shows only one element which is "Cannot connect to Windows Azure" 

    I've tried to download again the publishing settings signing in into Windows Azure from the publishing wizard, but when I try to import the new settings into the wizard I get the error  " The certificate for the given thumbprint could not be loaded from the Current User/Personal certiicate store. Please install the certificate". 

    In the meantime I've installed a fresh vm with VS2013, migrated the application project and published it with no problem at all. Unfortunately at the moment VS2013 it is non an option for me.

    Hope to earh from you,

    Thanks,

    Gennaro.
    Tuesday, February 25, 2014 8:08 AM
  • Hi,

    I still need help because I do need to update a "production" application.  Thanks a lot,Gennaro.

    Monday, March 3, 2014 8:15 AM
  • Unfortunately, the API to retrieve Azure Web Sites has been updated and is now incompatible with the LightSwitch Publish Wizard in v2 projects (VS 2012 Silverlight Projects that have not been upgraded by right-clicking on the project and selecting Upgrade).

    This means it is not possible to publish to an Azure Web Site via the Azure path of the wizard.  It is possible though to publish to an Azure Web Site via the IIS path.  Follow the steps in this blog post and you should be able to publish:

    Publish LightSwitch 2013 Preview Applications to Windows Azure Web Sites (without the Azure SDK)


    David Kidder | Senior SDET | Microsoft | LightSwitch

    Wednesday, March 5, 2014 8:08 PM
    Moderator
  • Thank you very much Dave, it worked
    Thursday, March 13, 2014 4:01 PM