none
HELP - [HTTP 401] : My ASPX page under WSS RRS feed

  • Question

  • We're using Windows Sharepoint Services 2.0 under Windows 2003 Server at http://Sharepoint (c:\inetpub\wwwroot). I;ve created a new web part page with my webpart added to it. The webpart adds lots of custom HTML to the page including a Flash .SWF object that enables users to bring up a file dialog box to select one or more files for uploading. The user can then click Upload and Flash will begin the POST submission of the selected files to the server.

    I have it set up so that my flash object submits the files to http://Sharepoint/myapps/DocUpload.aspx. This page takes in the request and stores the files as it sees fit. "myapps" folder is located at the root directory of the sharepoint site, so: c:\inetpub\wwwroot\myapps. I used managed paths to exclude the folder.

    The problem im having during file uploading with flash is i keep getting a HTTP 401 Unauthorized access just before uploading begins. The authentication dialog box appears asking for me to log in but even when providing the correct information it still asks for authentication (i am Admin). Sometimes it appears to accept the user info but uploading STILL does not occur.

    Just to rule out other possiblilties I tried creating a new website within IIS6 (http://test) and pointed it directly to the myapps folder. I also pulled out the flash code and had it plugged into a .HTM file. When i tried connecting with http://test/test.htm (to display the flash browse button) then submitted everything was ok (the file submission was poitning to http://test/DocUpload.aspx). When i tried using the http://sharepoint/myapps/test.htm (the page appeared fine) but on file upload submission the 401 unauthorized appeared (upload was to http://sharepoint/myapps/DocUpload.aspx).

    Its as if the http://sharepoint site is locked down in some way. I was thiunking it had something to do with the web.config file within the root sharepoint folder and so copied it to http://test/ root folder but nothing happened; everything worked fine.

    Any ideas what is going on? How do i stop sharepoint from issuing this 401 unauthorized when accessing my .ASPX page from my flash object? Connecting to the .APSX page directly (so from the browser address bar) works fine though.
    Tuesday, March 13, 2007 9:47 PM