locked
WSP and WHMCS RRS feed

  • Question

  • Hello friends

    I am getting some issues trying to configure WHMCS to work on the top of WSP.

    In details I am getting out this error from WSP:

    Uncaught SoapFault exception: [soap:Client] System.Web.Services.Protocols.SoapException: Server was unable to read request. ---> System.InvalidOperationException: There is an error in the XML document. ---> System.FormatException: Input string was not in a correct format. at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal) at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info) at System.Xml.XmlConvert.ToInt32(String s) at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReader1.Read47_GetMyPackages() at Microsoft.Xml.Serialization.GeneratedAssembly.ArrayOfObjectSerializer68.Deserialize(XmlSerializationReader reader) at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events) --- End of inner exception stack trace --- at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String e in 

    According to everything what I've been reading around I did not find anything that passes to my scenario. This because I am WSP using virtual servers instead of phisical ones (website space on server1, mail on server2, db on server3)

    Is there someone that made it working in such enviroment?

    Thanks, Giuseppe


    Giuseppe
    Saturday, February 12, 2011 8:55 AM

All replies

  • Hi Giuseppe,

    We have a similar setup.  We did run into some issues with WHMCS, but they were all something we had done.

    When you first things things up to test, try to uncheck as many options as possible in WHMCS to verify that it first sets up an account.  (Let me know if you already have this part working)

    Is the above error from WHMCS running on a win box?

    Monday, February 14, 2011 4:11 AM
  • Thank you Koby,

    Yes WHMCS it is running on a win machine.

    I did try to setup with minimal options but with no luck.

    Some other suggestion?

    Thanks, Giuseppe


    Giuseppe Pitzus
    Open Software S.r.l. - Italy
    http://www.opso.it
    Monday, February 14, 2011 9:34 AM
  • what are you trying to do? to provisionWSP from WHMCS? If yes, WHMCS should give you an error. what is that error number?

     


    Greetings, menefre
    Monday, February 14, 2011 11:29 PM
  • Hi Giuseppe,

    NOTE: We have our WHMCS running on a linux box.

    This shouldn't have anything to do with it.

    Does it setup normal hosting accounts without errors through WHMCS?

    Friday, February 18, 2011 1:12 AM