none
Missing Report RRS feed

  • Question

  • I created two reports yesterday in my Access 2013 <g class="gr_ gr_43 gr-alert gr_spell gr_inline_cards gr_disable_anim_appear ContextualSpelling ins-del multiReplace" data-gr-id="43" id="43">db</g>.  Today when I look in the Navigation window the reports are missing.  I configured Access to show all hidden objects in the Navigation windows and alas they are still missing.  I know the reports still exist because I have a button that opens the report through the expression builder.

    Any advice what happened and how to get the reports back?
    Thanks

    Justin

    Friday, June 2, 2017 4:54 PM

All replies

  • Hi Justin,

    What are the names of your missing reports? Do they start with "Sys" or "USys"? Just curious...

    Friday, June 2, 2017 5:16 PM
  • Or "MSys"?

    Dirk Goldgar, MS Access MVP
    Access tips: www.datagnostics.com/tips.html

    Friday, June 2, 2017 7:24 PM
  • Or "MSys"?

    Dirk Goldgar, MS Access MVP
    Access tips: www.datagnostics.com/tips.html

    Oh, yeah. It's what I meant. Thanks, Dirk.

    Cheers!

    Friday, June 2, 2017 7:54 PM
  • If you open the report and switch to design view, and put the following in its Open event procedure:

        DoCmd.SelectObject acReport, Me.Name, True

    then switch back to print preview or report view, what happens?  What the above should do is select the report in the navigation pane, so I'm interested to see if this would force it to be visible.  I've no empirical basis for thinking that it would, but until you try these things you never know whether they'll work or not.

    There's no need to save the report after inserting the code BTW, so long as you don't close it before reopening it.

    Ken Sheridan, Stafford, England

    Friday, June 2, 2017 9:01 PM